Can't Move a Model inside of a Part. The Model Appears on Top

Hello All,

I’m having an issue moving a Model. I have a semi-transparent Part in the shape of a cube. Separately I have a Model of a gem. Using a script, I want the gem to move into the middle of the semi-transparent part. I have attempted to move the Model using the script code:

game.Workspace.Gem:MoveTo(, 4, 51.335))

The numbers in the parentheses are the position of the semi-transparent part. When I run this, the gem always appears on top of the Part. Even if I subtract a little from the Y axis, it doesn’t help. Both the Part and Model have Anchored set to true and CanCollide is off. Here is a short clip:

robloxapp-20200825-1859347.wmv (114.7 KB)

Any suggestions on how to overcome this so the gem will appear in the middle of the cube?

You may want to use a model primary part and use SetPrimaryPartCFrame(your position) as MoveTo implements a collision check after setting the initial position regardless of CanCollide values. This is done instantly and you don’t see it happening on run time.


Setting a PrimaryPart then using CFrame worked! Thanks for the insight!