Can't move anchored parts in studio!?

So I just tried to rotate an anchored model in studio and it wouldn’t let me until I set all the parts to unanchored. The model I’m trying to rotate has only specific parts anchored so I can’t just use the ‘Anchor’ button on the home tab. Is there a way to get rid of that feature so I don’t have to unanchor all the parts and then re-anchor the parts that I needed anchored again? If this is an update to studio that I can’t get rid of then I’m very unimpressed…

If you want to keep a part where it is in studio, you should use the ‘Locked’ property. Anchored should only be active with the physics engine in-game. Am I the only one who thinks so?


Anchored parts can be moved with the Studio Tools.

You probably have Collisions enabled which would stop the parts moving through other parts.


I had constraints enabled. My bad, although I don’t even know what that is.


This will explain the constraints button:

Also you can mark my answer as the Solution to show that this thread has been solved. :slight_smile:


A post was merged out.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.