Can't move player on Xbox but can on PC with controller

Apparently the Xbox app got another update :roll_eyes: and it broke my game again. So in my game, Nerf FPS the player will spawn in but you can’t move around, I tried disabling and fiddling around with all the walkspeed and player movement functionalities in my game but to no avail.

I tried the same thing on PC and I thought I fixed the bug on PC because it was working, but when I hopped onto my Xbox, I can’t move the character around at all, it’s like thumbstick1 is doing nothing. There are no errors or anything, I’ve been trying to check everything but I need help.

2 Likes

Hey, would you be able to provide us with some more information?

I just tried your game on the current live build on Xbox and I was able to move the character around with no issues. Is your control script custom?

Also, are you testing this on an Xbox One or an Xbox Series X|S? There is a known issue with controllers on Xbox Series X|S in the latest Microsoft Xbox update

https://support.xbox.com/en-US/help/hardware-network/settings-updates/whats-new-xbox-one-system-updates

We’re aware of an issue in which some Xbox Series X|S controllers are losing connection with the console. If you see this behavior, try reconnecting the controller to the console wirelessly or with a USB cable, or if possible, connecting another controller and then submitting feedback. Then reboot the console and try reconnecting the controller.

I’m sorry I resolved the issue, it turned out the selectedobject was still on even after spawning in and resetting the camera/gui, so I just set the selectedobject to nil and it works now.

2 Likes