Can't open Roblox studio, Error 504

This is a support category for asking questions about how to get something done on the Roblox websites or how to do something on Roblox applications such as Roblox Studio.

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    Open roblox studio and continue my work.

  2. What is the issue? Include screenshots / videos if possible!
    Error 504, the connection dropped once, and I couldn’t come back. Image attached…

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    The only thing I haven’t done so far is reinstall studio, but I restarted my machine, checked my connection, logged in from create.roblox and triggered studio from there, and nothing.

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!


Issue resolved, I don’t know if it was this but I redownloaded roblox studio directly from create.roblox when you spawn the game from there. That, or someone has helped me in here, either way, thanks!

The Roblox Servers for Roblox Studio are back up from what it seems. I tried reinstalling right when it started but it didn’t work.

It seems to work now.