Can't play game in roblox studio

Hello, I have this problem when I try to play my game inside roblox studio. It just keeps loading but I never actually get to test my game…

The thing is that I can test the baseplate game from roblox without any problems…

What could be the problem?


Is there any chance you have a loop where there is no wait time such as:

until 1 > 2

instead of

until 1 > 2

No, I don’t think so, it seems to be a problem with studio, since I can play this game on roblox, but on studio it’s not working…

I would also add that I can play my game in studio from my other computer…

I suppose you could try uninstalling studio on the computer that studio doesn’t work on and checking for updates. Check if Roblox studio and your computer itself is up to date as well and your internet connection and provider.

Also, if you just run the game the game instead of joining like normal you might be able to check the output to see if anything is having issues. Also, have you tried joining other games on your computer and tried to see if they had the same issue?

Lmk if you have any more questions.

I uninstalled and reinstalled it. It still doesn’t work. It seems like the problem only occurs on my big games, like on baseplates it doesn’t happen since it doesn’t need a lot of processing power.

Hmm… is your computer particularly old? Also have you tried other games other than roblox?

No, I haven’t tried, I do play some fps roblox games and they are always running at 60 fps really smoothly. My computer is 2 years old…

Did you ever put any free models or potential viruses in the game? Also is the game still not loading?

I did, but even if i delete them, it still doesn’t work. I tried deleting everything in the game and leaving the baseplate but it still doesn’t work…

Do you have many Roblox Studio plugins? It can affect it too and make somewhat user corruption

Yes, I tried disabling them. I find the more I remove from my game the better. I tried removing everything but the baseplate, even including the plugins, now I can hear myself landing on the baseplate and jumping and moving, but the screen is still a grey loading screen.

Is there anything coming from the Output tab?

Not really, just some infinite yields possible. The funny thing is I woke up today and I ran it, and it actually worked. I’m starting to think it has something to do with some parts in the game, since I have another game, and it’s also pretty big, but it’s running fine.

for anyone facing the problem check the connection if it was blocked
if is make it that it allows the connect be double clicking it then allow
or allow if secure