Can't Publish Place: Internal Server Error 500

I’m currently unable to publish one of my games to ROBLOX. My internet is fine and I’m able to upload other games, but I receive constant error when I try to publish a certain rbxl to any ROBLOX place. I’ve tried uploading from my laptop, and I’ve tried both Publish and Publish As. What’s causing this and how can I fix it?

EDIT: After about 4 hours, it started working again on its own. Yay?


Well that would lead me to believe the file is corrupted somehow. Try re-saving it, or copy/paste everything into a brand new place and see if that fixes it.

1 Like

It seems to be a problem with the file size. I tried re-publishing an already published place to find the same problem. My upload speed is a little over 5mbps.

1 Like

How big is the file? I know ROBLOX has a upload limit for files, although I can’t remember what it is…

1 Like

It seems to be a problem with the file size. I tried re-publishing an already published place to find the same problem. My upload speed is a little over 5mbps.[/quote]

I remember the upload issue from this CSG thread but it says the cap is at 10 minutes, so I don’t think that should be a problem.

Try this?

1 Like

File size is 30MB. Smaller places work.

I’ve been getting the same error for several weeks, but my file size is 20 MB, and the upload speed is 1 MB/sec. In theory it should be able to be published in 20 seconds, right?

Anyone ever figured out how to fix this? This has happened to me in the past, but I just updated my game to work on a smaller file-size by using less models (resizing models in-game ect.). Now fast forward about a year later w/ even more content added and:

ATM my file size is at 49MB. Whenever I go to publish it’ll just send me an error within 5 seconds. I tried uploading an empty baseplate, and I have no problems at all.

I also tried uploading the same place file while deleting 10 models within the place which brought it to a size of 47.2MB, and was able to publish within about 10-20 seconds.

I re-pasted those models, and wasn’t able to publish again. I’m assuming it has to do w/ the file size & my current upload speed which is decent.

This is preventing me from uploading my game, so I’ll be trying to lower the file-size somehow in the meantime.

This has been an ongoing issue for me for a game I am developing for. The file size is 26.5 MB and I have never been able to publish the game to it’s place, or even a place on my profile.

There should not be an imposed limit on how long it takes to upload a game, or have an alleged file size upload limit (without it being openly documented). People have differing internet connections and game sizes, so I can’t see why there would even be limitations like these.

I have tried publishing normally, by clicking File > Publish, and I get this error.

And when I publish directly, to overwrite the game, I get this error.

This is the largest game in terms of file size that I have developed for, and it is the only game that I cannot publish. I have tried several times and have had zero success. This game is able to be published by other developers on the team, just not me. I have no trouble uploading other games, around 2-10 MB.


This issue is continually persisting for me, and after a google search of the error, I found a support article that provides no assistance to my issue (and probably to anyone else who has seen it, as only 1 of 8 people have found it helpful). The game may be large, but that can’t be the problem.

This is the only game file that I’m unable to publish. I have no problem publishing separate games, my own games, or to other group games. This is the only file in particular that I cannot upload. Everyone else on the development team I am apart of can publish this file, and I am the only one who cannot.

I speculate it is because my upload speed is 1 Megabit per second. Despite my inadequate upload speed, the publish should not time out internally because it may have taken too long (specifically 2 minutes).


This is still an issue.
None of my friends in the team create can save our place…We got this error on a few other places as well. There’s literally no way for us to fix it, we’ve waited and it still fails every single time.


Do not necrobump bug reports