Can't seem to make NPC animate when walking

  1. What do you want to achieve? Keep it simple and clear!
    I want to make an custom NPC walk with an animation.
  2. What is the issue? Include screenshots / videos if possible!
    I can’t seem to make them animate, they just slide on the floor
  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I tried copying the Animate script from player and replacing the ID’s

Format of NPC:


1 Like

the Player’s animation script won’t work because they are not players.

just use Animation:Play()

That still oddly enough does nothing. Is it something to do with the fact that I don’t own the group the game is under?

Did you publish the animation as yours or as the group’s?

Someone else published it to the group

make sure that the animation is published as an action or movement animation

1 Like

does that person who uploaded that animation to the group own the group/place?

Have no idea of knowing that because I haven’t touched the animation except for scrpiting it in

Nope, they don’t

30 wooedkkoko lalala

They don’t have to own the place/group for it to work

prob the reason why
the owner needs to upload it otherwise the uploader can only see it

i had that same problem when i uploaded an animation and others didnt see it
when we did some browsing we found out the animation needs to be uploaded by the owner

if this doesnt work am i just being confused or what

Can this have to do something with the new audio privacy update?

animations and audio is pretty much a different topic

They said they wanna roll it out to other stuff too

that incident happened before the audio privacy update so it isnt bc of that update

1 Like

You’d need to make the Roblox animate script a Script rather than a Local Script and it’s a good idea to remove any code snippets that are useless, like type emotes and any game.Players.LocalPlayer references to be the actual Figure you’re working with.

If the owner of the animation is the group, made by an ‘admin’ role then you should be able to view the animation, if not in studio then check playing the actual game. To be honest, dealing with permission, groups, player games, and animations between all of it is quite annoying and not well defined imo.

EDIT: Do keep in mind that changing “Humanoid” to a name that is different is a pretty good way to disable Roblox provided code. You may need to check through anything that references Humanoid and correct it to “NotHumanoid” or “Controller”… whichever is in use. Everything I’ve said assumes your rig is properly made and you have properly modifed the animation script

Yeah, they’ve always been janky. Did everything except middle paragraph, need to ask the higherups about that