Cant teleport the player to the CFrame i want


I have been trying to fix a problem that I have encountered but i just cant.

My problem is that i try to teleport the HumanoidRootPart of my player from the SpawnPoint that it Spawned to a parts CFrame but it just doesnt do anything.

I tried out of couriosity to add a loop to keep teleporting, when the player walked it could walk a little but then got teleported back to the SpawnPoint forever.

I also accidently pressed “Play Here” instead of “Play” and for some reason it worked and the player got teleported to the part i Wanted it to go.

Basicly for more Context, when the players Character gets added and loads, a local script sents a Remote Event to a Server Script and there it makes the player teleport to where i want it to.

I apologise if you are confused but I whould appreciate your Support

To teleport a player, you need to use PivotTo(), like this:

local position =,0,0)
local orientation =,0,0)


If you want to teleport a player whenever you like, you can do this:

local _CFrame = {
    position =,0,0),
    orientation =,0,0)

function teleportPlayer(player)
    if player.Character then

teleportPlayer(player) --Run this whenever you need to.

i tried it but it still does nothing

Hmm… Show your script this is a Script Support so if you can show your script.

If you want to teleport someone to a part, try this

local Part = game.Workspace.Part -- Your part goes here

	local Character = Player.Character or Player.CharacterAdded:Wait()
	local HumanoidRootPart = Character:WaitForChild("HumanoidRootPart")
	HumanoidRootPart.CFrame = Part.CFrame

Ps. “Play Here” makes you character spawn on the position of your camera in studio.

Here is the Client Script:

Here is the Server script:

A CFrame is a position and orientation, so you can specify where to teleport to, and what direction to look at.

You can learn more here:

For line 10, just do this:

player.Character:PivotTo(game.Workspace.Level1SpawnPoint.CFrame +,5,0))

it still does nothing, though when I instead of press “Play” I press “Play Here” it does work, is this maybe because of the SpawnPoint? Does it do something that prevents the player from teleporting?

What do you mean by pressing either “Press” or “Press Play”?

I mean the button that you click to play your game in studio, It has 3 options, Play, Play Here and Run, When i Click Play i doesnt teleport the player and when I Click Play Here it does work for some reason.

“Play Here” just plays the game, teleporting your character to where you were looking at during in roblox studio.

yes, when I click Play here instead of play it does work and teleports me to where I want to, thought when I click play it doesnt do that.

Because “Play Here” teleports you to where you’re looking at in Roblox Studio. It’s not your script working.