Can't upload or publish games

Just wanted to say I’m also starting to experience this. I’ve been able to publish and save the place I’m working in with no issues in the past but all day today I have been unable to publish and save. Looking forward to a solution. Thanks.

Sorry, don’t know how to send logs, but it’s just started happening to me as well today. Studio did update for me about 6 hours ago.
I get the following output:
00:12:47.291 - Tracked vehicle & Suspension tests auto-recovery file was created (x4)
00:17:00.356 - Tracked vehicle & Suspension tests publish failed.
00:17:47.238 - Tracked vehicle & Suspension tests auto-recovery file was created
The issue is that I get the unable to publish error message on my Studio screen, but if I go to the game on the website and play it’s updated to the save that was supposed to have failed.

Have you downloaded any new Roblox studio plugins lately?

This has been happening to me, but only in some places. It publishes and saves just fine, yet still gives me an error and claims that the save failed. I’ve been experiencing this for the past 3 days.

I have a saving problem like this since yesterday. Luckily, I have it saved to Github with Rojo, but its still annoying.

I’ve also become affected by this issue. Last night I tried to push an update to the dev version of my game and noticed publish was failing. I then published to the test version and it worked twice before failing. It has not worked since then.

I too am having this issue - it started today as far as I know. For the past few days I have been saving fine then today came and this very issue occurred.

see here:

3 Likes

Only just started having this issue the now, forced to save on my backup drive. Restarted studio but no change. Saving the games does function but I am unsure about the reliability of it. image

Happens to me to. @Regal_Corgi I will send my logs when I get on my computer tomorrow

This bug was happening to me last night and I couldn’t publish my game. This morning I tried again and it said the same thing.

However when I checked the actual game I was trying to update it was actually published with all of the updates to my game.

Please try to spend a bit more effort looking around the forums in the future: (linked at specific post explaining how to send log files)

2 Likes

Started happening to me as well. At first it would happen occasionally, but now it happens every time and it’s impossible for me to save/publish.

It started happening to me yesterday and its still doing it today, my friend and I made a lot of work and we don’t want to lose all of the work we did so we just have to stay in studio the whole day until it starts working again.
image

Best bet at the moment is to just save it as a file, work on more things then overload the file whenever you make changes.

I downloaded a copy of the place, I think that should do so for now because I think I completely lost trust with the save and publish function.

I cannot “publish” from my internet connection for some reason. Using a VPN I can using the same internet connection, in fact it is the only way I can publish currently. There may be a bad internet route between your ISP and Roblox servers, so try using a VPN if it fails as it will force Roblox Studio to use a different route for the upload.

I have also been experiencing the same issue for the last 10 days. I have also tried uninstalling and reinstalling Roblox. I also tried with a VPN but the same errors shows up in Output.

2 Likes

This started happening randomly so I can’t publish/develop any game at the moment, hope roblox staff will check it out in future.

2 Likes

There are multiple reasons why a publish can fail. I still cannot publish unless I use a VPN so there is some lingering network issue going on with the Roblox cloud.

If your place is too big or has other issues its also possible it will fail to save/publish then too. In that case you could try saving/publishing a small place and see if that works, and if it does maybe try to see if there are any errors in the one you cannot publish. There really should be better error explanations for why a publish fails.

I also tried different places and even different accounts, and the same message appears.