Can't zoom in and out while holding shift

Hello my game has a sprint feature that uses the shift key, and I noticed that if I try to use the scroll wheel to zoom in and out of the screen while holding shift it doesn’t work. I disabled the shift lock so that isn’t the problem.

I also tried this in a new baseplate world, and discovered the same issue. So its none of my scripts that’s doing it. Does anyone have a fix?

Seems like this is a major design flaw on roblox’s fault, hope we can get an update on this. The current solution I have in mind is to change the sprint’s key to something else, but that’s pretty lame.

What? Mine works just fine, both studio and in game. Does it only happen on roblox? If so, have you tried to reinstall/reset? If not, check your drivers and (Windows) settings to see if there are any conflicts.

i’m on a mac, when i do shift and scroll wheels it does nothing on studio but when I play the game it rotates the camera. Very weird behaviours… It could be related to the OS we’re on? Here’s the game: its uncopylocked

mac uses shift + scroll to horizontal scroll lol. its a mac problem, you can disable it using 3rd party apps to fix it, but your average roblox player won’t have an issue with this. some games fix this by having toggle to sprint or double tap w (like deepwoken) but nothing you can really do about it


man just macs being the being the worst pc to ever exist again :roll_eyes:
who would have thunk it

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.