Car models are working when published but do not work from Studio

Hello All,

I’m just starting to get into vehicles and am having a major problem right off the bat.

I got a free model car “Jeep”, and when I attempted to use it, it does not move forward one stud… it does all other stuff like sound, wheels rotate, etc, but it does not move.

What is weird is that when I published my place, and attempted to ride the model from the Roblox site, it worked!

So I went and bought the ‘Red Convertible’ item thinking that perhaps the free model had something wrong, but to my surprise, the red convertible is also showing the same problem - it does not run in Studio, but runs from the website after publishing.

I’m thinking there might be some Studio configuration that is missing? I have the HTTP Requests and the API Services enabled.

Would anyone know what can be wrong here? Why would a car model not move forward at all in Studio, but drive normally when published and from the site? Do I need to adjust some settings?

Thank you!

2 Likes

Can I see the script that is inside the vehicles?

Sure, here is the free model Jeep that I got, which again, works fine from within the site, but does not work from within Studio.

FreeModelJeep.rbxm (44.8 KB)

The jeep works fine for me
I don’t know why its not working for you

Edit: Try setting the AvatarType to R15 and see what happens

I have it set to R15 and no change, still same issue where the car remains idle while the wheels are spinning.

Okay, thanks for checking though! I am going to continue messing around with my Studio Settings and see if I can catch what is wrong. I’ll put an update here if I find the issue.

Weird can i have a screenshot of GameSettings > World?

You can Use This Jeep

Here is goes:

Let me try this one too… but I have a feeling it’s something on my Studio causing this as I also bought a car from Roblox site with same issue (does not move in Studio, but moves in published Place).

OK try and Let Me Know
This One Is Roblox’s Default Jeep Found in templates

Hmm I thought the gravity would be changed but it wasn’t I’m pretty much out of ideas I don’t know what could be causing this since it works fine for me

1 Like

Nope, same issue… all looks to be working but the movement forward is not happening with this Jeep either.

1 Like

ohh Then it might be your studio’s problem
Try Reinstalling it

Okay, that’s another option I can do if all else fails. Thank.

Awesome! You gave me the idea to just RESET all my STUDIO SETTINGS and that worked! Thanks for the help.

1 Like

No Problem, In Future You can help Somebody with same Problem

1 Like