Certain 3D sounds won't play at all

So this has been an issue for a few weeks now and seems to be linked to some sound updates that have been made recently. Certain audios will play only if they’re not in a part or if I click Play in the Studio UI.

This audio includes:

I’m sure these aren’t the only ones but they’re the ones I’ve discovered so far. I’ve used a lot of these myself and this is well over a thousand robux wasted in sounds that don’t work. I re-uploaded some of these and that didn’t fix it.


  1. Put sound in Workspace and type workspace.Sound:play() into the command bar. The sound should play.
  2. Select the sound and click “Play” in the Studio UI. The sound should play.
  3. Put the same sound in a part in Workspace and type workspace.Part.Sound:play() into the command bar. The sound will claim to be playing but won’t actually play.

System specs:

  • Windows 10, newest updates
  • Sound devices:

Any other information that is needed I will gladly provide.

1 Like

I’ve ran into similar trouble before and the issue turned out to be running into a cap for the amount of “3D” sounds that can be played at the same time.

Maybe this can help you out :slight_smile:

This issue occurs even when no other sounds are playing on the entire system, even immediately after a reboot. I don’t think it’s that.

It’s also always the same sounds that don’t work. Ever since they stopped working I haven’t heard them playing once as a 3D sound.

I’ve only tried 343920538 and 343920433 but both of them seem to work for me. Can you post a place where this does not work?

I just tried rbxassetid://343920433 and it played fine in all scenarios.
There is one thing to note, sounds don’t play when a simulation isn’t running. I tested them in run/play solo.

Strange, for me sounds will play/not play based on these conditions regardless of whether or not the simulation is running.

Have you tried setting the EmitterSize to 1 and the Volume to 10?

Yes. Absolute silence.

Have you upgraded/changed your OS recently? That broke some things on my old laptop.

Do you have any sound drivers (like equalizer APO)?

I haven’t had any Windows / driver updates installed after the problem started occurring.

I have the same sound drivers that this computer came with, and with which the 3D sounds used to work.