CFrame.Angles not Rotating?

Hello, I require assistance in this small problem I have.

For some reason, no matter the CFrame.Angles input, it will refuse to rotate at all.

I’ve tried browsing to see if anybody has the same issue as this, but I couldn’t really find anything - the solutions the others provided was only relevant to model parts, not player parts. I’ve tried using SetPrimaryPartCFrame as well, but it also refused to work (same outcome)


The sword gets stuck like this the entire time (Even with different angles) Sorry if this is a dumb question.

Could you provide the part where you actually set the CFrame?

If that is the whole script just so you know, listing a variable as a property of an instance and then applying changes to that variable won’t do anything to the property of that instance. The variable is basically it’s own property. Also you should use a WeldConstraint because welds set position based off the C0 and C1 offset properties.

Its because you are setting the variable instead of the sword CFrame?

Also using math.rad on 0 is useless because 0*(math.pi/180) is 0

try using

handle.SwordBasic.CFrame = SwordCF

That won’t do anything because of the weld, you should recommend using a weld constraint or using appropriate CFrame offsets with the weld he’s already used.

You need to modify the Welds C0/C1 to get an effect.

local weld ="Weld")
weld.Part0 = rArm
weld.Name = "HandleWeld"
weld.C1 = CFrame.Angles(0, 0, math.pi/2)
weld.Parent = rArm

Also please use GetPivot() instead of GetPrimaryPartCFrame().

1 Like

I currently just woke up and don’t have access to the studio yet, but thanks! I’ll try these when I get back home.