.Changed does not fire when connected to local scripts


#1

Connect a .Changed event to a local script, and the event will not fire when the LocalScript’s name or ‘Disabled’ property is changed.

  1. Create a local script anywhere
  2. Create a script anywhere or a local script anywhere where it will run, and connect a .Changed event to the local script in (1).
  3. Change the name of or disable/enable the local script on the server.
    Expected behaviour: The event set up in (2) is fired.
    Actual behaviour: The event is not fired.

#2

I can’t seem to replicate your problem. Are you sure you’ve set it up correctly?

What I did:
Created 2 local scripts inside Character. First one prints .Changed events on the second script.
When second script is changed on the server, first script successfully prints all changed variables.
It works with all scripts combinations - LocalScript/LocalScript, LocalScript/Script, Script/Script


#3

I just reloaded my saved file after restarting my computer and tried again, and it works now. Problem solved I guess? Not sure what happened, same set up and same actions.


#4

I’ve also had this happen and thought it was a bug, but it worked in game.