Changing Graphics Quality Renders ViewportFrame Models Incorrectly

Reproduce Steps:

  1. Join a game with visible ViewportFrames that contain models or parts
  2. Change graphics quality via Roblox Settings upward. (this does not occur when lowering graphics quality for some reason)
  3. Watch the models in the viewports partly or completely disappear

The bug happens in-game and occurs every time I follow the above steps and it started today (that’s when I first noticed it).

System specs:
Macbook Pro running on macOS Mojave 10.14.16
3.1 GHz Intel Core i5 with Intel Iris Plus Graphics 650 1536 MB


^ As you can see, the eggs are partly rendered and the 3 pets on the far right are invisible now…
1 Like

Followup: The bug now occurs when Graphics Quality is set to Auto. When the quality changes on its own, the children of the ViewportFrame become visible/invisible. Right now, lowest Graphics Quality settings gets the highest clarity for the ViewportFrame children. :confused:

Since the bug still persists I went ahead and replaced most of the ViewportFrame instances in my game with ImageLabel renders of in-game assets. Only took me ~8 hours to render and upload all of the images, but I had to come up with a work around this bug.

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up here when we have an update for you.

2 Likes