Changing mouse.icon works in studio but not in game

Hey everyone,

Recently I published an update to my closed Flight Simulator, and my testers noticed that the cursor on the plane kit GUI is no longer showing. Upon further investigation, I had not changed ANYTHING regarding this code and so it remains a mystery. It fully works in studio but oddly doesn’t work in game.
I have tried re-uploading the decal etc but no luck.

Here is the code:

local FlightCursorID = 9630933088
Mouse.Icon = "rbxassetid://"..FlightCursorID

I have also tried:

local FlightCursorID = 9630933088
Mouse.Icon = ""..FlightCursorID

Decal link: NewCursor - Roblox

I have doubts that it is a scripting issue, given that everything works absolutely fine in studio.

If any of you have any ideas, it would be greatly appreciated.


Would be great if you provided any code, thanks.

1 Like

The fix was to make the cursor a 256px256p image, it works now that I’ve changed all my icons to this image size.

Can you show me the image please ?


Post edited. Thanks :slightly_smiling_face:

And you are still using Mouse.Icon with this method?

Check this out


This fixed my issue, many thanks :slightly_smiling_face:

They are the same image, just different sizes.