Character moving animation wont play at all

I’ve tried changing the animation priority of the animation and everything is unanchored. Please help me. It’s a custom rig.

Hey. I cant really understand what you mean if you dont provide any information. Please Show us scripts, Outputs and maybe a video.

There’s nothing in the output that display an error in the script.
I’m using the default roblox animation script.
Here’s a video:

It worked at first, but suddenly it stopped. The animations are uploaded on my account, so is the game. I have tried changing the priority. I’ve also checked so that there’s nothing anchored.

Also, when i check what the humanoid state is, it always says it’s running. It does the same on all the other rigs, but they work.
This is a bone animation.

Thats weird. It shouldn’t just stop out of nowhere. I’ll try to find out

This should work.
Put a script in ServerScriptService.

		char.Animate.walk.WalkAnim.AnimationId = "rbxassetid://YourID" = "rbxassetid://YourId"

Change The “YourID” part to you animation ID.
Tell me if this doesn’t work.

It’s already set and doesn’t get replaced.

Wdym? do you have a animate script in your custom rig?

Yes. I just told you. There’s a modified version of the roblox movement animation script.

maybe try deleting that and put the script I gave in ServerScriptService.

I have tried your way in the past and it didn’t work.

Also is your rig R15 or R6

I don’t have to change the animation. I’ts already correct.

Can you provide some code? We can’t do much from a simple explanation.

Didn’t you read? It’s the default roblox movement animation script.

Can you show what the hierarchy of the rig is (Motor6Ds, parts)?