Character scale acting weird

So i am making 2 potions for a game 1 to make the player smaller (works) and one to make the player bigger.

However, the potion that makes the player bigger does not seem to work, i have tried countless of hours trying to fix it but no.

This all happens on the server and once printing out the scale it does become the correct value, zero errors no nothing.

The thing that makes me most confused is that the small potion works fine and it has the same code in both potions!

I have recoded it multiple times, printed everything out and searched on the devforum. I can’t find any solutions as the posts do pretty much the same thing as i do.

(Will include code snippets in a moment)

Thanks in advance,
LinusKat - Reality Creations

What are you using to scale the player?

You can find it here:

try this


The first thing i did was ScaleTo but it also did not work for bigger sizes than one

thats strange, it worked for me. can you show me your script

For anyone wondering what the problem was that might have this issue in the future,

I made a script inside the tool do everything but you need to put a script into ServerScriptService that handles the potions.
The initial script had to be on the client firing that event to the server with the size included.

Thanks to “gameknight_10” for helping.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.