Character Scaling Doesnt Work

As seen here, there are no values, so i cant use a script to resize them.
I tried it locally, but that didnt work either.
AutomaticScaling is enabled, but i have no idea how to disable it.
Any ideas on how to change bodysizes without those values in the humanoid?


I dont want to change body colors.

This isn’t changing body colors, it’s changing the entirety of the humanoid model. If you don’t want body colors then don’t apply them. You can use the properties in the “Scale” table on that page and reapply the description when you’re done.

There’s the Humanoid.(BodyDepth/BodyHeight/BodyWidth) Scales.

I have altered them before by just getting the exact ratio of them related to each other than multiplying by the scale I want. There’s probably easier solutions out there though.

thing is, i dont have those values.

You can just not apply whatever u want?

If you don’t have those values just press play, when your in the studio look at your character then the humanoid, and it shows all of those.

That doesnt work either. I see no values.

If you don’t have them, then make them? I’m not too sure where the point of problem is.

All the scaling values will be NumberValues, where the number represents a value multiplied by 100 to get a scale percentage (e.g. value of 1 == 100%). The following four scales will be the most relevant to you:

  • HeadScale
  • BodyHeightScale
  • BodyDepthScale
  • BodyWidthScale

There are 1-2 more for Rthro scaling but I don’t remember what they are and I doubt they’re applicable to your use case. I believe they’re Proportion and Type or something like that.

HumanoidDescriptions will or should automatically create these values for you if you don’t have them. You were recommended then earlier and they solve your issue as they support applying scales.

I tried, but it messes up my model.

I want to ask, is this a R6 character model?

No, its r15, whenever i change it the torso becomes too big.

Could you supply more detail than this? I can’t understand what problems you’re running into with a single sentence. Show us code, pictures of what’s going on, how you’ve made set ups, everything. You need to be detailed with your responses.

I assume they are having the same issue as mine, my custom characters don’t have these values, so I added them manually, however it messes up the animations. :man_shrugging: