Character suddenly pointing in odd directions and limbs animating incorrectly

Today I’ve been experiencing an odd issue that I have never seen before. This was NOT happening yesterday and was suddenly happenening once I booted up studio today so I have no Idea if this is a roblox bug or not. This also doesnt happen in-game and only happens 50% of the time when I play in studio. I have no idea what could be causing this. If anyone has had any similar issues can you tell me how you fixed it?

I really can’t understand what are the issues in the video shown. Can you please show

  • what is supposed to happen?
  • what actually happened?
  • what methods have you tried solving the issuese?

I had a similar issue when attaching something to a character while an animation played distant from the RootPart.

I fixed it by stopping the animation and waiting one frame (task.wait()).

Interestingly enough, it also fixed by changing anything in the character’s descendants using the explorer.

I doubt this is related but try checking if your character tends to offset from the RootPart.

1 Like

Heres what its supposed to and usually looks like until suddenly this morning.

Ill give it a try real quick, one sec.

1 Like

I agree with @ShutzCh, the video you sent (what’s supposed to happen) has the root part attached to the character model, hence the camera doesn’t look weird compared to what actually happened in the video shown in the original post.

1 Like

Its attached fine but it is moving very oddly. Its almost like the animations are playing correctly but the humanoidrootpart is just shifting upwards in high speed movements. I checked collisions and nothing seems out of the ordinary.

Does your character spawn differently than usual (scripting wise)?
What method do you use to attach stuff?

Then again if it happens when moving then I’m not sure it has to do with what I experienced.

1 Like

My character spawns in a separate spawn room and is teleported to its spawn once the loading screen is gone. I heard there have been changes when it comes to teleporting characters. I’m currently using :SetPrimaryPartCFrame().

Oh I just looked and saw SetPrimaryPartCFrame is deprecated. I was not aware of this. I’ll try a newer method and post what happens after.

1 Like

I changed :SetPrimaryPartCFrame to the new :PivotTo and the issue is still happening.

and to attach things I use this module.

For some reason, turning off StreamingEnabled completely fixed this issue?? I guess this is a roblox bug after all.