Character taking forever to load in Play Solo

Happens inconsistently after every publish or major script change (?). Could also be a combination of my not-high-end Windows 10 PC and something else. I’m unsure if this issue is entirely on my end right now.
At other times the character loads at a normal speed.

You can usually predict when it’s going to take ages to load the character by how long it takes to load the solo test (I’m assuming because of the publishing/script changes that it has to re-build the place?).

During the wait time when the test has loaded but the character hasn’t, :LoadCharacter() does nothing, and you’re just left sitting there in free camera with no character, StarterGUIs or anything else.
You can seem to skip the wait by stopping the test while waiting for the character and starting it again.

I believe it has started happening recently - it’s been maybe a week since it started for me.
I find it very disrupting to my workflow.


I get this too, game loads in but it takes about 2-3 minutes for the character to load in, I’ve got a pretty beast PC so I wonder why this is happening… (And only over the past few weeks)


I think it’s a bug. I get this too.


If you guys can provide us with a place that has a repro, it would help us a lot finding the issue.

I believe the issue has disappeared for me recently. I’ll let you know if it happens again, though. Could be because I’ve been working a lot in only 1 group place for a while.

Happens on an empty baseplate (new file) for me without plugins installed/enabled, so on pure vanilla.

It appears to hang on something related to loading my character’s appearance, or something at all related to my character’s contents, since it typically only happens when I haven’t pressed Play Solo in a few minutes or so. When it does happen, it is not unusual for it to take like 20-60 seconds before my character appears. Scripts run fine before the character appears, it’s really just that the character doesn’t spawn until a disproportionate amount of time has passed.

Gif of me pressing Play Solo: (aptly called PlaySolong.gif)

This gif was not taken on an empty baseplate, but that’s basically how long it takes on a baseplate too. I can take a new gif on a baseplate to show the same behaviour if necessary.

I run Windows 10 Pro, Studio version 0.338.0.202976. I’m connecting from Europe (in case the server where it’s fetching things from is different for Europeans) over a 300Mb/s ethernet connection (i.e. wired, so this is not Wi-Fi shenanigans). My player’s user ID is 1659965.

As mentioned, a baseplate (new file) is the repro.

@FarazTheGreat Let me know what other information you need to repro this. It’s really killing a lot of my development time because I can’t quickly test small code changes.


It’s hard to tell without being able to repro. Does microprofiler show anything? Have you tried un-equipping almost everything and seeing if the load time changes?

Issue is still happening. It either gets stuck for 15-30 seconds starting play solo (gets stuck about 1/3 into the green progress bar at the bottom) or boots instantly but doesn’t load my character for 30-60 seconds.

Nothing interesting on microprofiler seemingly.

It seems to affect any outgoing connection in the Studio window. For example, if I run a HttpService/DataStoreService query in command bar after not touching Studio for a while, that request will take 15-30 seconds to complete, while requests made after that are near-instant.

I figured it may have to do with settings of my antivirus, so I tried disabling firewall / real-time scans entirely, but it had no effect. Also, I have not experienced any such issues with other programs that I use that need to do web requests.

Please let me know if I should get you any log files or microprofiler dumps or anything like that. This issue is really impacting my productivity if I have multiple Studio windows open because I’ll hit a wall as soon as I leave a Studio window untouched for a few minutes.


Do you see Studio lagging overall? Like typing scripts or showing and hiding widgets?

Not at all, this all seems to be instant and there’s no delay in typing in scripts.

Can you please PM me the contents of the following folders:

If you’re on Windows:

  • Put %LOCALAPPDATA%\Roblox\logs into the file explorer address bar. Zip the content
  • Then switch to %localappdata%\Local\Roblox\logs\archive and zip the content

If you’re on Mac:

  • Open Finder, open “Go” menu, select “Go to folder” and post ~/Library/Logs/Roblox there. Archive the content

This is now occurring again.


I thought it was fixed in Accurate Play Solo for a bit, but it seems like it just occurs and doesn’t occur based on the particular time at which I’m developing. Just had to stare at my window for 25 seconds for my character to spawn in with Accurate Play Solo.

1 Like

This has now regressed even further: it now even happens sporadically when I press stop and press Play Solo almost right away, whereas earlier it would only take ages for my character to load once every couple of minutes.

1 Like

Another update:

The issue does not occur when a StarterCharacter is defined, even if that starter character contains character meshes and accoutrements. It will load instantly, 100% of the time, whereas it will not when your own player character is used. This indicates it is related to asset loading.

cc @DreamingMind

1 Like

Thanks for letting me know. I will involve our Networking team to research the issue further.


I’m still running into this issue regularly. Whenever I hit the play button through Studio, it can take up to 15 seconds to load my character and spawn. It seems that spawning in consecutive studio play sessions is as fast as you would expect, but the issue reoccurs seemingly randomly without restarting Studio.


I’m also still experiencing this.


I’m also experiencing this. Re-entering Play Solo seems to speed it up.


i am unable to replicate this problem. the description suggests that this happens when assets are not cached, but there may be other issues. we are looking at better ways to get diagnostic information from users in a situation like this. I am writing a trouble shooting document. in a day or so i will share it. i would appreciate any feedback. the goal is to ultimately gather this information automatically, but until then, the document will reflect the question i usually ask.