Character Texturing not loading

Hello! So I am currently trying to make a character for a game I’m helping to develop. I have the model but when I try to export it to Studio, all the texturing is gone.

Here is the model in Blender:

And here is the model in Studio:

When I use the Mesh Importer, it says that the texture files couldn’t be found but I don’t know how to fix it. Here is a screenshot of the mesh importer:

Thanks for the help and sorry for the trouble.


This is not the correct category to post this issue in. I’m not going to flag your post, but I would suggest moving it to a different #help-and-feedback subcategory.


Ah ok. Yeah I was wondering if this was the wrong category. Wasn’t sure which one to put it in. I’ll change it now. Thanks.

You should try baking the textures into your model, as it I’d say it is likely the reason the textures aren’t being exported with the model.

1 Like

Sorry if this is a dumb question. How do I do that? I’m not very experienced in blender. I’m mainly a scripter. I’ve looked up videos but all have either been way to confusing or straight up not helpful.

I’m sorry for the trouble. I just kind of really need to get this done in order to progress in development.

1 Like

Yeah you are good man, blender (and 3d modeling software in general) aren’t exactly intuitive. Basically “baking” a texture just means it turns it into one single 2d image that can be layed out over the model. First, you should just do a bit of uv unwrapping by just selecting some edges at places where a border would make sense (like a sharp edge or where a texture would be different). Then just hit the unwrap button under the “UV” dropdown menu in the context bar (shown in the image below)

Once your uvs look nice and fine(which usually is just relatively straight islands that maximize the space in the uv plot), go to shading tab and add an image texture to any of the materials (don’t connect it, if you do it won’t bake from what I remember) then hit the new button on it and create the resolution you want it to be (I’d say like 2K, as roblox I believe won’t let you upload images above 1K right now and it never hurts to have a little extra detail). For every other texture you want to bake onto the model, make sure you put an image texture in them as well and set it to that newly created image texture. Now, here is the part you should definitely follow. Go to the properties tab (most likely on your bottom left of your screen) and hit the tab that has a white camera icon (2nd topmost icon). Once you are there, click the drop-down menu next to render engine at the top of that tab and switch it from Eevee (basically a much faster version, not as QUITE as good looking as cycles) to cycles. This engine is good for rendering high quality images at the cost of performance (though it is being massively improved with each new version of blender) and which is why a few new tabs will appear now. If you look towards the bottom of properties tab, you will now see the “Bake” tab. Open it. You will see a few important things to remember in this tab, those things being the Bake button, Bake type, and influence (things like selected to active and output can also be important, but it’s best not to mind them for now). Because you are using just plain colors, you have no need for the bake type to be combined, which would bake things like roughness,metalness,and ambient occlusion (which are mainly used for PBR texturing, aka Physically Based Rendering AKA what a ton of engines used to make realistic materials). What we want is the “basecolor”, which in this case is the diffuse option. Select “Diffuse” in the Bake Type. There is one other thing you want to do before you bake it. Inside of influence, you will see Direct,Indirect, and Color. Direct is direct lighting like if you used just a regular light pointed at it, and is useful for baking shadows. Indirect can take a lot longer to bake, as it is light reflected by other objects and is something you will likely not use and should DEFINITELY turn off, as it can make the times for it to bake FAR longer than what you want. Finally, we have color of which you should probably never turn off, as it is literally color and you probably don’t need to just bake shadow images for this. So I’d suggest just turning off direct and indirect but you can leave direct on if you want to bake some shadows for some reason. Now you should be all good (don’t worry about “Bake from multires”, it has to do with the multiresolution modifier which you can learn more about if you like) and just hit the bake button. Considering it is just color, it shouldn’t take long and you should see the imagine in the bottom left view. In that view, hit the 3 lines → Image → Save as and then save it as whatever you would like. Now that you have baked it you can also change the engine back to Eevee and if you would like to, make one material for the entire mesh and just connect that image texture to the Base Color in the principled BSDF to see what it looks like. Now all you have to do is export as obj (don’t export as fbx, as both roblox AND blender have problems with fbx because Autodesk, the company who made it, left it as closed source and therefore neither company has inner knowledge of how it actually works). Now you can just export it as a .obj file (wavefront) to roblox and import it into roblox and it should work. If the texture doesn’t show up for some reason, just go to the texture property of the mesh part and manually import it from where you saved the image. If you have anymore questions you can ask me directly.

(Also sorry for not formatting this better, its just a lot of stuff to type)

1 Like

So I baked the textures onto the model but when I try to use Mesh Importer it just says this:

it’s doing the “Can’t find image file” Again


Sorry for the trouble.

1 Like

Hm, I haven’t used import preview before so I don’t know what it could be at this point, especially considering the image show that it clearly found the baked texture yet somehow isn’t working. That seems kinda odd. I suppose that I really can’t help you further due to the fact that all I usually do to get meshes into studio is just use meshparts and import the mesh and texture file manually. Sorry.


Select the mesh in studio and set the Textureid as your texture file. If your UVs are correct, everything should appear fine.

1 Like

There are too many triangles. The limit is like 10k and mine is 12k. That’s why I tried to use mesh importer because of the limit being 21k

I don’t follow. Are you saying that you can’t apply the texture because you used the new mesh importer?

Oh sorry I misunderstood. I probably could do that if it would let me import the model in the first place.

Hi. I managed to get it Imported. And then did what you said to do. And it work! :tada::tada::tada:

Thanks very much for the help. Now we can continue development!

No problem, glad I could help! I assume you also have PBR materials for that model?

If not, here’s a free software to easily create PBR materials:

The website isn’t loading for some reason, know any alternatives?’’

EDIT: It’s working now! But some alt’s would be nice, thanks!

There’s no alts. It’s just the one website.

1 Like