Characters have a new part called 'NewHead'?

Hello fellow developers!

I was recently working on my game when I noticed a bug. When I jumped out of my car, I got pushed back into the distance! I looked into the character model of my player, and there lay a new addition called ‘NewHead’!

Is this a bug or is this a Roblox intended feature? If so, it is causing my character to fling a lot. I wanted to bring attention to this since it can potentially destroy other games.

The NewHead is invisible and does not follow the player!

How can we remove this?


As far as I know this is not something roblox does, are you using any freemodels or plugins that inject scripts, you could use ctrl+shift+f to search through all your scripts and maybe find something?

I tried using an Anti-Virus checker and it did not reveal any problems. I find that this also happens in almost all the games that I create!

A antivirus wont check for Instance creation, use ctrl+shift+f and search for to find a cause.

This is something that only you experience so it’s probably not something on roblox their side.

I have done what you suggested to and found no ‘’ that I was unaware of. Could this be a bug from Roblox’s side? I know it can’t be, but maybe a new feature? Is this happening to you?

It’s happening to nobody, only you. You should probably check your plugins for anything they can be doing.

Edit: Grammer

1 Like

Disabled every single plugin. It still injects this part called ‘NewHead’. I am removing this by looping through every player’s character and destroying it, but I want to find out why it exists.

Is this happening in an empty baseplate? It might be your character too.

Yes this is happening to every game I create. Why would Roblox allow an invisible head to be purchased (Not counting the headless head of course!)

It might be a part inside your head. Would you try changing your whole avatar and seeing if this happens?

I changed my avatar to the basic ones which are typically free and now it has two NewHeads lol

skill issue
Looks like a roblox issue. I’ll check this later today and respond, if I’m getting this too then u might want to make a bug report.

1 Like

Alright! Thanks for the clarification!

I think this happens with older vehicle models and it won’t happen as often if you make or use a newer model.

Hmm… This doesn’t happen when I enter a car. It happens everytime I join a game!

Yeah, that’s sounds familiar. It happens a lot when using older car models or playing older games with vehicles. It normally only happens if you jump within a certain vicinity of the vehicle. So I think if you are spawning close to the car that might be why. Have you tried using a different car model or making a new one? I think that could fix it but I don’t know because I am semi new to game development. Other than that I don’t know what could be going wrong. Can you send me a screenshot of each script in the vehicle? I’ll get back to you later about it.

Umm… I don’t think this issue is related to cars. Everytime I jump towards the invisible NewHead part, it flings me. It happens in an empty baseplate too! I don’t think vehicle models or scripts would have anything to do with it.

It’s definitely a bug though. It happens quite often

I agree, and it must be fixed!

When did this start occurring? Like before or after you got in the car. And can you send screenshots of the car’s scripts?