Characters join the game but do not proccess any scripts

If a player joins my game, their character will spawn; however, after some time, it is confirmed that they do not load (literally nothing in StarterPlayerScripts or ReplicatedFirst will ever run).

I have a local script in StarterPlayerScripts AND ReplicatedFirst that will immediately :FireServer() to print a message. These messages print for me and everyone I’ve tested with, except for many people joining the game through the ads. I cannot correlate a difference between us and them. I have tried everything.

It is also worth noting that I get this error when they disconnect, meaning they could not process an :InvokeClient(), proving that none of their local scripts have run.

Additionally, I have whispered and tried to talk to dozens of these users, who have never replied. They likely have not seen the messages I have sent them. None of these users (hundreds of them) have ever disliked the game.

Why can’t these players load in? Is this a result of something I did, or just a standard expectation for Roblox users? Are they bots?

I just got news that some guy had bad phone connection, so it took him 13 minutes to load in. Does Roblox really spawn the characters of those who are on mobile in their cars with horrible connection?


Did you use WaitForChild()?. You’ve gotta wait until it fully loads so it will wait for the scripts until your character has completely.

1 Like
game:GetService("ReplicatedStorage"):WaitForChild("Remotes"):WaitForChild("Misc"):WaitForChild("LogErrors"):FireServer("RepFirst: Ran for "

This is the script I run. I put this in a local script in replicated first. It does not fire.

1 Like

Question: do your remote functions return anything? If they dont try replacing them with remote events.

1 Like

No, the client never runs the remote functions. They yield forever on the server and close after the player disconnects. Remote events have the same issue, it waits until the player is fully loaded to process them. The player is never fully loaded.

This was a result of crashes related to voice chat. I am looking into resolving these crashes and will update this if necessary.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.