Choppy Camera while moving around, big FPS drops

When I use my Steelseries Sensei Wireless mouse, my Studio will dip down to ~10 frames per second while moving the Camera with Right mouse button. It also moves very choppy.

However when I swap my mouse for a wired one, it’ll not experience any of these issues.

To fix this, I’ve tried enabling Hardware mouse, re-installing the Sensei mouse drivers, re-installing Studio and disabling all Studio Plugins. With no effect.

It happens in any place, even on empty baseplates.

Here’s a video of the bug in action:
Midway through the video I start using my Wired mouse.

I can’t exactly pinpoint when it started happening. It might have been a few months ago.

System specs:

OS: Windows 10
Processor: i7 5870k
2x MSI GTX980 Graphics in SLI

1 Like

Please post a microprofiler screen capture during the frame rate drop.

The Ogrewidgets seem a little out of place. I hope this helps!

Some frames during dips take up to 0.6 seconds for some reason

Every hyper-long frame seems to have a big gap inbetween, and then ends with an OgreWidget

We’re taking a look, and will be ordering that specific device.

Does this problem happen in the normal game client on your system?

Thank you!

No, I’ve not encountered anything like this while using the normal game client. It only happens in Studio.

1 Like

I’ve got the mouse in question and am unable to reproduce this problem, even on the highest DPI settings. Any ideas of any other settings that could be related?

I haven’t experienced it on my laptop either, it’s only on my desktop that I have this issue. Are you using the software that came with the mouse (SteelSeries engine 3?). Could that potentially be the cause?

I’m not sure what else could be causing it at this point, either some weird driver related issue (but I reinstalled my mouse drivers), or my Studio just being completely out of wack somehow (but I also tried reinstalling Studio).

Do you have any tips?

I also have another problem related to Studio that started happening around the same time, where I get a 1-second delay between clicking on Parts and selecting them:

Which also looks a lot like a problem from October 2016:

The microprofiler in that thread looks a lot like mine, “Ogrewidgets” and “Ribbonbars”.

All in all I have a lot of problems with Studio on my desktop and re-installing doesn’t seem to help :frowning: .


  1. Removing all installed roblox studio plugins.
  2. Killing (from the task manager) any running programs.
  3. Uninstalling SteelSeries engine 3 (I do have this installed, btw)
  4. Use the SteelSeries Sensei mouse on your laptop. Does studio still have the same problem?
  5. Try with a fresh windows installation on your desktop. Maybe in a new partition.

And seeing if you can pinpoint the problem.

Hey Spotco,

Thanks for the tip!

As per your suggestion I’ve been strategically killing programs in Task manager. After a while, my camera ran smooth again. I can’t exactly pinpoint it to an exact program because it seemed to gradually get better. I think it may had have something to do with a drawing pen / tablet service.

I still have some frame dips whenever I hold Left mouse and select a bunch of parts, but far less severe than before.

Do you have any idea what might be causing this? Here’s what one of these frames looks like:

See if you can isolate which program it is. If you’ve got a specific drawing pen or tablet drive, that sounds promising.

I think I’ve managed to minimalize the issue to the point where it’s barely noticeable :slight_smile:

Thanks for the help, spotco!

A post was merged into an existing topic: Off-topic and bump posts