Choppy Shadows Issue

So, for some reason, when I use a surface light and future lighting to have everything cast a clear shadow, my shadows end up all choppy, and I am not entirely sure why.

I have tried adjusting shadow softness, playing off of studio, and testing it on a separate baseplate with the same variables. From what I understand, this seems to be an issue with the fact that I am using a surface to light up my game since when I tested with spotlights and point lights I don’t get that issue.

Let me know if you guys know of any possible solutions to this.

1 Like

If you go into Roblox studio at the top left corner and press the File button press the Studio Settings go to Rendering and put the Editor Quality all the way to 21 or something that is good looking enough that wont lag. If this doesn’t help I don’t have any more answers, sorry.

1 Like

Increase shadow softness maybe?

Surface lights are extremely scuffed in Roblox for some reason (weird speculars, bigger part makes shadows lower resolution), you’d probably be much better off using a spot light.

4 Likes

spotlights do the same thing

Unfortunately, my render quality was already 21 when I took that photo. I am 90% sure this is just because surface lights are so scuffed.

I’ve been having this issue as well, im happy that it has been finally addressed!

2 Likes

I see. Using spotlights removes the issue; however, using a spotlight doesn’t give the same effect as a surface light, but there aren’t any choices left, lol.

1 Like