'Cleanup' will not consistently close all windows / failed to load published place

Reproduction Steps

This is untested on other games/baseplate, but my game is a very large publish and thus this could be to do with opening/closing large places.

Expected Behavior

Pressing ‘Cleanup’ after creating a local test server should successfully close all clients.

Actual Behavior

The majority of the time, it does not successfully close them. This happens in two ways:

Or:

  • The clients seem to have closed, but hidden processes still linger, causing any future local server tests to malfunction with a ‘Failed to load published place’ on the server window and ‘Failed to connect ID: 17’ on the clients

    studioerr2

Workaround

Manually close all created clients/server or use task manager to force close them.

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Often
Date First Experienced: Since at least October/November time?
Date Last Experienced: 2023-01-23 00:01:00 (+00:00)

8 Likes

I experience this every time I hit cleanup as well, I need to manually close each client.

Happens to me too, worked perfectly in the past.

Thanks for the report! We are aware of the issue and we’ll follow up when we have an update for you.

2 Likes

Can confirm this issue happens on a newly opened baseplate file.
I’ve had this issue happen consistently since 2020 so it is not a recent issue, I just haven’t taken the time to make a report myself.

I’m also experiencing this issue. Really annoying when you are constantly opening two player local servers to quickly test minor changes, it might seem “minor” that you have to manually close each window but doing it 20 times over in a 10 minute period quickly becomes deeply frustrating.

2 Likes

Hi, we’re consolidating some of our bug entries. We’ll be tracking this issue over here

Hi,

just x-posting:

An attempt to fix this issue has been released (and turned on) if you are using the latest Studio.
Let me know if you are still experiencing this issue or not.

Thanks