Clicking Play creates a new server

Clicking the green Play button creates a new server for one server games.
This happens when you are under the “Preferred Player Count”

This also occurs in Universes servers. They create new servers instead of joining multiplayer servers


Can confirm I’m getting the same problem now… :confused:


This happened in my game Heist, so I had to completely change the teleport code to use reserved servers rather than just the old :Teleport() system. (The game uses a universe & Create Place API).


This bug is still appearing in my games and I’ve been losing a ton of visits due to this bug1.PNG

1 Like

It seems to happen when two players press Play at the same time


This bug is still ongoing and I really hope for a fix soon


I still get this bug, clicking play will put me into a new server instead of an existing one, this is at any place on ROBLOX including my own.


Still got this bug :confused:

Any news on when this will be fixed?


Yes, this is extremely annoying.

1 Like

I thought it was just me. We’ve been having to leave and rejoin each others servers for months now.

It would be great to know when this bug is going to be fixed.

I think I’ve lost a ton of potential players due to this bug, but since I’m non-profit, I’m not heavily as affected as opposed to some of you guys who might suffer from this bug really hard.
I hope this bug gets addressed soon. It’s been hard maintaining players since they keep thinking no one is playing but there were actually four 1-2 players servers.

Off topic:
I find it strange ever since the robloxdev website’s been moved to this new forum, the admins of roblox doesn’t check this forum section as often anymore.

Probably because nobody took the time to make a repro, so I took the time to make one. This issue seems to be related to the one described here, so I guess I might as well mention @spotco

Here’s how you reproduce the bug: Go to any game’s page with no players in it (in this case I just tried it on a BasePlate I uploaded: BasePlate - Roblox). Next, ask someone to go to the same page. When you’re both on the same page, click ‘Play’ at the same time. It doesn’t have to be exactly at the same time, but make sure there’s not too much time in between. After you joined the game, click the ‘Servers’ tab on the game’s page. You should now see two servers, one with just you and one with your friend in it:

1 Like

Cool, I’ll take a look.

I made a post earlier about Teleport behaviour, and I imagine the “Play” button has similar behaviour as non-PlaceInstance non-PrivateServer teleport.

It is definitely possible there was a regression in server launch-to-discovery time, though that definitely isn’t behaviour that should be depended upon.




This is really bad because most games are not fun with only 1 player and if all your players are splintered out into their own servers your game can never achieve critical mass and get popular.

In my opinion this is a deal breaker for using Universes with Teleports. You should design games in a way that never require you to teleport anyone anywhere.

1 Like

How is this a deal breaker? This looks like a bug and not intended.

Yep, it’s not intended, but there aren’t any plans to fix it :(

Edit: switched quoted thread to one with more info

So TeleportService:Teleport will not necessarily try to fill up servers? I don’t remember this being the case before

I don’t know what it does internally (I think it tries to), but the thread from the new quote (I switched it to a more informative one) says the issue for both teleporting and joining from the site is possibly related to an increase in servers, which is making it difficult to do that (at least from what I understand).

1 Like