ClipsDescendants being ignored

Every UI instance seen here has ClipsDescandants enabled. Not sure how to go about fixing this.

1 Like

In what way is it being ignored? It looks like it is functioning as it should. More insight and I can help you

1 Like

Every time I’ve ever used ClipsDescendants, the way it works is it would stop UI from appearing if its position is outside of its boundaries. As seen in the video however, this isn’t applying. Let me color the background so you get a clearer look. You can also see the selected instance highlighted in blue.

Even with ClipsDescandants on for this scrolling frame, the frames are still appearing outside of this. This isn’t normal behavior.

So, correct me if I’m wrong, the issue is that the images aren’t clipping as they should but the text and its respective background is. Could you send me an explorer screenshot of the ui? Oh and also, what is the ZIndex of the image border thing that is not clipping correctly

1 Like

Yeah, the text such as shield, clothing etc. and their backgrounds are clipping properly. However, a few of those thin border frames are not clipping.

The zindex for everything right now is 1.

Could you scope more into the actual gui objects that arent clipping correctly in the explorer? Right now it’s only just the frames

Here is the button selected that is on the far right in the scrolling frame. As you can see, it still has a frame visible.

Still not a helpful explorer screenshot at all to be honest. Are the non-clipping borders image labels? If they are where are they on the explorer.

Additionally, there could be something wrong with the position of the gui object you’ve used for to clip it’s descendants. Perhaps it doesnt cover the entire line?

This should show you more

And no, they aren’t image labels. Just frames, and some have UIGradients in them. Deleting the UIGradient does not fix the problem. I don’t see anything wrong with the parent scrollingframe that could be causing an issue. The reason I’m not showing all the children in the screenshot is because the buttons are created by functions so they are all the same, aside from their text.

Okay so “Buttons” has clipdescendants on, and all of it’s descendants have clipdescendants off, correct?

Buttons has it on yes. The children also have it on, but turning it off makes no difference.

Here’s a vid showing the problem in even more detail

I’ve just tried replicating your problem and I literally can’t. Buttons should have clip descendants on, and all of its descendants shouldnt. There shouldn’t be any problems this way.

Perhaps there is another overlapping scrolling frame or other instances interferring with the clipping?

Are any of the elements rotated? ClipDescendants will only clip un-rotated elements. CanvasGroups can, however, be used to clip rotated elements.

1 Like

Let me just upload the UI here. See if the problem happens on your end.
InventoryWindow.rbxm (65.3 KB)

Yeah, they are rotated. Rip. Time to look into CanvasGroups.
Edit: Changing it to canvasgroups was really easy.

It’s now working as intended.

How did you achieve that UIBlur btw?

this useful module


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.