Cloud edit "Invalid parameters" when connecting

So, I woke up to this Studio issue. I can edit any game that does not use Cloud Edit (Team Create) but if I try open anything using Cloud Edit, this error occurs in the output.

I’ve re-installed Roblox and this is still an issue, any ideas?


A friend just attempted to make a place use Cloud Edit and it kicked him out. I am also unable to join any Cloud Edit places though.

I’m having the same issue ever since studio updated.


Same problem, just uninstalled studio to try to see if that fixes it.

I tried creating a new team create place and it booted me.
My brother also tried re-uploading an old version we saved to the team create place and it crashed.

I am having the same issue on all of my cloud edit places.
Hope this gets fixed soon, I got work to do :frowning:

If you want to download your game to work on it locally, you can do so by going to

and it should prompt you to download a file. Download that and add .rbxl to the end of the filename to convert the file type and voila, you can continue working on it locally.

1 Like

1 Like

Yes this is happening to me and two other players that tweeted to me about it.

In addition to the error in output, this dialog shows up.


1 Like

Yeah if Roblox could just fix this that’d be great. I have work to do :smiley:

1 Like

Looking into it. We’ll get this fixed ASAP!


Yey that worked… Also glad the site checks to make sure you can’t download other games. (Awesome)

This should be fixed now. Sorry about that!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.