Cloud Localization Table doesn't immediately populate after updating

Importing a localization sheet to Cloud Localization doesn’t update the tables in a timely manner. Upon uploading my CSV to the cloud, it takes me 2 or 3 test sessions in Play Solo before the translations are ready to be in the game.

This happens every single time I upload a new sheet to my game. No matter the size of the sheet, internet speed, anything. Tried this on two different network connections - one very slow and high ping, one very fast and low ping. Tried this with two different sheet sizes, one 800+ lines and many languages, one less than 100 lines and no languages. It seems very consistent.

Having this downtime makes it incredibly difficult to test out localization changes that have to do with setting up format strings. Adding onto this, the fact Cloud Localization doesn’t load in F6 Play Solo makes testing out changes even more annoying and time consuming.

We ran into this tonight and thought our code was broken (it wasn’t) because of this + the F6 test bug :confused:

It took ~3 play solo sessions for the list to eventually update and then our localization started working.

1 Like

We are actively investigating this. Thank you for the feedback!

It seems this issue has come up again, except in a different form. I had a lot of new terms translated to Brazilian Portuguese, but whenever I go into game and test out to check on them, they are not showing up. Except for the already existing terms that just had the br-pt column updated. Downloading the sheet shows me that they are on the cloud, and the localization portal says the same thing.


Sorry to necro, but three years have passed and it’s still very much a problem, this was the only relevant result when I Googled it.