Collision Group glitch

Issue Type: Other
Impact: Very High
Frequency: Constantly
Date First Experienced: 2021-05-06 15:05:00 (+03:00)
Date Last Experienced: 2021-05-07 11:05:00 (+03:00)

Reproduction Steps:
Quite hard to reproduce this issue freely on your own but can be experienced at [Car Dealership Tycoon] (🚗 +2 CARS! 🚗 Car Dealership Tycoon - Roblox) for PC users. Works fine in studio, mobile, tablet and console. Most likely caused by collision groups, objects that should collide with each other doesn’t collide.

Expected Behavior:
When you enter the car, wheels should collide with the ground and you should be able to drive around normally. At the moment it works fine for mobile, tablet and console. Doesn’t work on PC.

image

Actual Behavior:
When you are playing on PC and spawn a car, collisions are not working properly, wheels clips through the ground which results in that the car is not drivable. Both the car and the ground are connected to Collision Groups and should collide with each other. In studio game it works flawless.

Workaround:
I have tried several workarounds but no success since collision groups doesn’t work as it should or used to work for PC.

9 Likes

Can you elaborate on how you use collision groups in this game?

It appears to be related to Upcoming Optimization to Collision Detection System - Beta Test on Mac Clients soon

Our internal collision group tests seem to work.

4 Likes

We have exactly the same problem in Hot Wheels Racing. Started around 14 days ago. The workaround was to make the collision group collidable with itself.

2 Likes

Yes this is the same issue! Works when I made the wheels collision group collidable with itself. Can drive the car normally but instead other features in game wont work such as races where you should not collide with other cars and players :confused:

2 Likes

Yeah 100% sure it’s related to that topic.

So in the game there are collision groups for wheels and bodies for cars. Wheels should not collide with each other but the ground, important for cases like races or when you have collisions settings disabled in game when you don’t want to collide with other cars in the game. As @GMaxZet said it works if I make the group collidable with itself, but again it disables some other important features in the game.

2 Likes

Would you be able to make a simplified repro case using the Beta Feature setting (Accelerated Collision Pipeline) in Studio? Self-Collision shouldn’t affect how the group collides with other groups.

3 Likes

Jeep_AndCollisionGroupWheels.rbxl (130.7 KB)

Here is a place where the wheels cannot self-collide, but they can collide with the ground. This place seems to work 100% fine.

4 Likes

Yep seems to work fine there.

I have the same game Car Dealership Tycoon published to a private place by mine, the collisions have started to work as they should again (didn’t work for an hour ago). Still doesn’t work properly in the official game.

Hard to do a simple repro then when it has started to work on most places but not the official game.

1 Like

Have you changed anything in the official game recently? I’ve been unable to reproduce this issue.

2 Likes

Not what I know about, the place files are exact same, whenever I publish to other places it works. I will check through some settings.

1 Like

Currently works properly in the official game!

1 Like

So I haven’t changed anything at all. I was trying to gather info if I need to disable my feature. I’m extremely confused.

I don’t see anything in the logs on Roblox’s end either…

2 Likes

Man it’s not clear for my side either :thinking: Very confusing. Something must have changed at least in the last hours. I swear I tested many different ways this morning. And I didn’t change anything at that time when it stopped working in game.

1 Like

Maybe the Beta Feature setting (Accelerated Collision Pipeline) affected something in game?

Much thanks anyway, I hope it will remain working now moving forward.

1 Like

I don’t think it’s Beta Feature, because I can still see that this is enabled via Microprofiler. If you see the stepMidPhase scope in physics, then the feature is enabled.

If it starts happening again, can you please message me and reply to this thread? I’m going to be keeping an eye on this.

3 Likes

Alright very spooky bug if you guys didn’t make some changes for it to work :sweat_smile:

I will let you know if it happens again :+1:

1 Like

We had that issue in live game and we did not publish like for 10 days, so we were pretty sure that it was roblox issue, as we saw release notes for the update n. 475:

2 Likes

BTW, we made the tracks/roads’ CG collidable with itself to get around this issue. Not wheels’ CG. Let me know if that works for u :slight_smile:

If you have a repro of this ground issue I would appreciate it.

Would you be able to verify whether it happens with the Accelerated Collision Pipeline Beta Feature enabled vs Off?

1 Like

Sure. I’ll test it now and I’ll post here the results.

1 Like