Color Picker Window "Pick Screen Color" Targets an Incorrect Screen Location (With OS Scaling Options Enabled)

Issue Type: Display
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2020-10-31 00:10:00 (-04:00)
Date Last Experienced:

Reproduction Steps:

  1. Make sure to apply a zoom to your display from your OS settings (I’m on Windows 10, IDK about Mac). My zoom is by default at 125%.
  2. Create a means of color viewing, i.e. a Frame for UI or a part in workspace.
  3. When manipulating the color, select the color picker icon to open the window up.
  4. Click “Pick Screen Color” and move the cursor around different regions of the screen. The cursor will usually be slightly off the color that the color picker chooses. I moved mine around the edge of the baseplate meeting with the sky to really capture the colors.

System Info
Intel(R) Core™ i5-4210U CPU @ 1.70GHz

Expected Behavior:
I expect the color picker to pin point my mouse position, not be offset from it. For example, in the image provided, the color picked should be gray. This can be really useful from trying to get tiny regions of color, such as studio scroll bars for plugin color themes.

Actual Behavior:
Note, this is during 125% display zoom, when switching to 100%, it works perfectly.

Below is a frame with my cursor over the gray baseplate, but the frame itself shows the color of the sky:

image

It seems that in this case, the color picker is choosing above the cursor, but I can’t guarantee that that always happens (it may be offset in other directions depending on the zoom).

This happens as well in the script editor color picker (it’s the same window after all no matter how it’s opened). I know for a fact that this been happening since Oct 31, 2020 when I initiated development on
AMP. Or it may be occurring since I switched to this computer in July 2020 that requires 125% for legibility.

More info here.

Workaround:

  1. I guess for now, you’d have to intentionally displace the offset to even it out (i.e. in the current case, just move the cursor a bit below of where I want the color to be chosen from).
  2. Set display zoom to 100%, although this will be very small, so I wouldn’t really do this.
9 Likes

Is this happening on Windows or Mac?

3 Likes

I’m on Windows 10. Also, restarting my computer doesn’t help either.

Are you using a high resolution (2k, 4k, higher)? Do you have any special scaling options enabled for Studio? I do not have this problem on a 1024p monitor.

2 Likes

@PeZsmistic and @swmaniac

It does seem like the issue is with my display scaling options. I have a high pixels per inch, so my OS recommends 125% zoom, which is what causes the offset. When I briefly switched to 100%, the color picker works as expected:

RobloxStudioBeta_xONwJM18yn

100% scaling is way to small for me, so I cannot permanently change to that. Studio’s color picker should respect the OS scale settings.

I will reword the topic and title to reflect my findings.

2 Likes

Hello! Thank you for the report. Unfortunately, this issue is caused by lack of DPI scaling support on Windows for Roblox Studio and resolving the underlying issue is currently not on the roadmap.

4 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.