Color wheel theme does not match dark mode

A bug I discovered when using studio was that after Roblox changed the studio logo an update was pushed out, changing some parts of studio. But one thing I noticed was that when using the color wheel when changing the color of Color3 the theme was not matching my dark mode.

Repro process:

  1. Open the color wheel by changing the color of a part, UI object, etc
  2. You’ll notice the background is white (when dark mode is on)

This issue wasn’t happening beforehand. Not entirely sure if this is only a macOS issue, if it is or isn’t please let me know

Device specs:

  • iMac 21.5", late 2013
  • macOS Catalina 10.15.4
  • Studio version 0.465.0.417678 (latest)
2 Likes

Could be possibly due to the color wheel window not supporting dark mode, do you dark mode enabled on macOS?

If I remember correctly, it should have a dark theme

Before Roblox pushed out the update to change the studio logo, I’m 100% certain that it was dark, but now it’s inconsistent and needs to be fixed.

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

2 Likes

There’s a work around by opening Roblox Studio’s Info.plist file in a text editor, and changing NSRequiresAquaSystemAppearance to false.


There’s probably a reason it’s set to light mode only by default though

Hey, sorry for bumping this but there are other parts that are inconsistent as well, including opening the file select menu.

Repro:

  1. Go to your studio homescreen
  2. Go to the top right and click “FILE”
  3. Select “Open from File…”
    It should show up as white rather than dark.

Using current studio version

Device specs:

  • MacBook Air 13", Retina 2020
  • macOS Big Sur 11.0.1