ColorSequenceKeypoint is weird

I’m trying to insert a particle into a UpperTorso, which works well, its changing the particleEmitter.Color that is weird. At first, I tried and it didn’t work with an error stating that I need to use ColorSequence, so I tried that and nope, now nothing works!

Please, help, I need it! This is probably the most advanced thing I’ve ever made, out of everything, even though its only 1 line lol

Code (everything works great if its inside of StarterCharacterScripts except the color part):

local Players = game:GetService("Players")
local player = Players.LocalPlayer
local character = player.Character or player.CharacterAdded:Wait()

if not character or not character.Parent then
	print("No character found.")
	local particles ="ParticleEmitter"),, 1, 0.498039))
1 Like

ParticleEmitter.Color uses ColorSequence and you can use the first of its 3 functions, change it to this

particles.Color =, 1, 0.498039))

PS: if this solved your problem, please mark it as a solution.

1 Like

I’ll mark it but I got help from Discord instead. I was using it entirely wrong, apparently you have to make a whole sequence (which I should’ve researched before posting here).

Not necessarily, if you use the first Color function it will paint everything that color.