Combine :GetPrimaryPartCFrame And :SetPrimaryPartCFrame


As a Roblox developer, it is currently too difficult for new users to understand how to tween the PrimaryPartCFrame of a model. For most users who know how to implement this as a function, you still have to go through the work to create it. TweenService is just an example. If x:GetPrimaryPartCFrame and x:SetPrimaryPartCFrame were just combined to become x.PrimaryPartCFrame not only would character count decrease, but we wouldn’t need those redundant functions. This most likely would improve a user’s workflow considering the use of a model’s PrimaryPartCFrame. It would most certainly improve mine, currently I have a function that uses TweenService to tween a model. Implementing this property would remove that function. Just a simple proposal however, any feedback would be great.

EDIT: Yes, you can access the PrimaryPart directly and change its position. However, it only affects completely unanchored models.


Model.PrimaryPart.CFrame ?


If you were to set that on an anchored model, only the PrimaryPart would move. Which then you would have to resort to :SetPrimaryPartCFrame. Instead a PrimaryPartCFrame property would be nice to have so it’d work on unanchored and anchored models.


It appears as though thou art correct, my bad


Like the Elizabethan English!


Why do we even have :GetPrimaryPartCFrame()?

There’s nothing different??


Probably because SetPrimaryPartCFrame exists tbh. The only benefit of SetPrimaryPartCFrame is that it moves all the other parts within the model too (albeit this suffers from precision errors, so you still have to write wrapping code around it to properly move around models).


Either this or method tweening (like Godot has), or both.

Support xd