Command Bar doesn't work

Using the command bar does not work at all.
If you try printing a string to the output it doesn’t work.

A private message is associated with this bug report

4 Likes

Just tried it a minute ago. I used print("test") and it works fine for me.

Maybe a glitch in your Studio? Try closing out of Studio then restarting, or if that doesn’t work uninstall and reinstall it.

2 Likes

Tried it.
There’s also another guy who reported the same thing earlier today in the discord devforum server.

1 Like

Ah, k.

This is the kind of information that would be helpful to put into your post so other people are informed about what you’ve tried.
All extra information is helpful.

1 Like

I am also having this issue, however my friend that works closely with me isn’t. It’s weird.

I am unable to use the Studio command bar to complete any tasks - I instead need to go in-game via Studio and use the console to do them.

1 Like

Also experiencing this, kind of an inconvenience because I use the command bar to adjust the Size of ParticleEmitters.
I’ve even disabled enrolment in to beta features and still not working.
RobloxStudioBeta_2023-05-15_09-34-33

1 Like

I’m facing the same issue. I think it started happening after I installed the latest version of Microsoft Visual C++.

1 Like

having the same issue, dont know what sparked it.

1 Like

Having this issue, I often use the command bar to test visuals like tweens or particle emitters or do some quick math with print, this issue is really getting in the way of things

2 Likes

Currently having this issue too, I semi-regularly use the command bar to test mathematical formulas over a range of inputs and not being able to output results makes it useless atm.
I only noticed it for the first time this morning but I am not sure how long it’s been happening.

I tried restarting studio but it didn’t fix the issue.

Studio version: 0.575.0.5750424 (64bit)
System: Windows 11 Home (Version 22H2; OS build 22621.1702)
Processor: 12th Gen Intel(R) Core™ i7-12700H 2.30 GHz

1 Like

Thanks for the bug reports. We tracked down some suspect changes and they have been reverted. In the meantime, our team has requested more specific examples of usages where it failed.

  • Did it fail in Edit mode, but not Play Mode? Vice-versa?

  • Specific commands previously put into the Command Bar, with expected and actual responses

This info goes a long way to track down the underlying cause.

5 Likes

in my case it does not work in any case. it doesn’t execute any code, destroying parts, printing things, iterating through loops, you name it. command bar refuses to execute code however it’ll list the code I attempted to run.

image

3 Likes

The command bar is working for me now!
image

2 Likes

Thanks for looking into this, it appears to be working now for me :smiley:

Additional info for original bug:
I don’t have a pic but I had the same issue as @hotpocket285 where it would print the code I’d entered but not actually do anything else.

All my testing was done in edit mode in studio.

This was the original code I was trying to run to test a formula.

local num = -1 for i = 1, 10 do print(math.cos(num + i)) end

When it didn’t work I tried just doing some print statements and even a simple print(“Hi”) wouldn’t print but the code from the command line would still show up in the output.

4 Likes