Constantly Lose Connection to the team create session

Hello, I’m not sure whether this is the correct topic. I’ve just been in the studio for about 25 hours, working not only today but every day, and I ran across an aggravating issue that turned out to be numerous difficulties.

First, I was in studio and then went in game to test after publishing. While testing, studio disconnected from the session and went to its homepage, thinking it was an internet error or something, but when I rejoined studio and fixed the bug and saved and published, I was kicked out studio says connection error while I am in game and my internet is fine. I was confused, so I went to bed. The next day, I tried to enter studio to the game while connected in the game, but it said failed to connect and kicked me out. Of course, I struggled redownloading studio and trying every possible solution, so I thought if I entered another game in studio, it might fix? Then I tried that, and it really worked with another game, so I went back to my primary game to see if it was fixed, and it was!

Now we get to the second current issue, which is publishing. Now I’m having a publishing issue where I basically save the game and push publish. It just states sending message to the server for publication, followed by a loss of connection and a random code like 000.000.000 | 000.00 or anything with numbers. I’m perplexed, and it occurs all the time. I restarted my PC and was able to publish other games except my primary game, which had previously worked flawlessly. Is it due of the size of the game? or is it all the result of a bad internet connection? If it’s because of how large the game is, I’m sure my internet is OK, but I’ve been coping with it all the time, and it shouldn’t happen after 2 months of working in the game, so please assist.