Copying Animate script to adjust walking animation not working

  1. What do you want to achieve? Keep it simple and clear!
    What is it causing it? How do I fix it?
  2. What is the issue? Include screenshots / videos if possible!
    I have overridden the walking animation with my id but it doesn’t show up on game
  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I have looking at previous posts at fixing this but none of them worked. Also I tried readjusting the id values in HumanoidDefaultAnimations

Try Changing the Run Animation Instead of the Walk.

Also When Changing It Ensure you change the Id part in the script and the Id in the Animation Object in the String Value Child of the Animation Script.


How would I get the Animation object? Every time I copy the Animate script, all the values get deleted and only pastes me a script.

It Shouldn’t.

Go To Studio > Click Test > Go to Workspace > [Your Character] > Animate

Copy that then stop Testing and paste back into the game. That Should copy the entirety of the Animate Script along with its Children.

Ensure you move the current Animate Script out of StarterCharacterScripts so the default one is not overridden.

is it possible to do it with a script?

No Idea Why Its Acting so Weird For you. Every Time I Do This It works like a charm.
Anywho here is the File!

Animate.rbxm (9.4 KB)

Thanks, I just the value in the Animation Object and in the script. The script got overridden but the object has a random id