Corrupted animation backend data

Reproduction Steps

Try to get the data for the specific animation: (or try the asset page:

Expected Behavior

The list of animations should load correctly and i should be able to see the information for that specific asset too.

Actual Behavior

I basically cant see the animations for my group, it just shows up an empty page in the studio toolbox and the create website. And all this is due to one of the animation’s data corrupting itself.

I opened the devconsole and the response of the api call to get the animation data just shows: {“errors”:[{“code”:0,“message”:“InternalServerError”}]}

I managed to track it down to a single animation from the list it searched and it was the one with id 10138775101. Right now i cant do anything because the edit page for the item is broken and i cant even load the information page for it.

Btw i know this doesnt exactly fit in the engine category, it just really doesnt fit correctly in any category, and this one is the closest one

Issue Area: Engine
Issue Type: Other
Impact: Very High
Frequency: Constantly
A private message is associated with this bug report


Same situation, i have 2 instances in my Animations that doesn’t even show the film icon,
which results in a 100% failure rate in loading the Animation assets on the website, overwriting the asset is also a failure.

Those 2 assets we’re made during a timeline Roblox was refusing any form of publishing
(this includes model, places and assets)

it happened Today (December 10th 2022) 8am EST

EDIT : HTTP error: 500 on a attempt to update the corrupted asset


I am now experiencing the same issue but with audio too: 3 audios in my group got corrupted and now the list of audios shows nothing for my group, and i have the same error 500 internal server error message when i check the network request.


First of all, are you sure this is an engine bug? Roblox should make a new category for Web-Based API bugs.

Second of all, this has never happened to me before.

I remember seeing one of my assets have a broken edit page (though that was fixed a while ago), what does it look like?

You’re right, its not an engine bug, but it really isnt a website bug either, its a backend bug. And there isnt any category for that so i placed it in engine. The edit page for these basically looks like this:

I have actually never seen that page before. Did this happen to old assets or assets that you created recently?

So for the animation, it was an old one. But i had the same error with audio too, and that was a new one i uploaded, but errored out however still got “uploaded”, but as a corrupted asset of sorts.

1 Like

Hi there, thanks for reporting this issue. Looks like when there is an issue with one asset, it’s causing the list of assets to fail which should not happen. We will look into fixing it.


Hi lrogerorrit,

We shipped what we believe is a fix for this issue by making lists of assets load correctly even if there is a malformed animation. Can you check and see if the issue is resolved for you?


I’ve just checked and the issue seems solved in some situations. In the create page it seems fixed for both sounds and animations (i had the corruption issue for both), however in studio, its a bit different. Sounds are still failing to load.

and animations load the first page/batch of animations, but when scrolling down, it doesnt load any more animations.


Hi @Irogerorrit,

We believe we fixed the issue. Can you let us know if you are still experience it?


I’ve just checked (after studio update) and in studio, sounds still fail to load. However, it seems that now also animations fail to load.

Both seem to work fine in