Crash when you switch CollisionFidelity to PreciseConvexDecomposition without beta feature enabled

When you select CollisionFidelity for meshparts, and arrow down to PreciseConvexDecomposition, it crashes your studio. This was first reported to me by @skylerlc, who said it crashed him while he was scrolling through the options for CollisionFidelity.

This only happens if you don’t have the beta feature enabled.

I recorded a repro as shown in the following video,

Do pardon the mouse position, it’s offset to the upper left of where it actually is due to my mouse’s DPI, the steps done in the video is as follows,

1 ) Right Click on Workspace > Insert Meshpart

2 ) Select MeshPart > Browse through CollisionFidelity using arrow keys

3 ) Studio Crashes

Provided below is the specifications for the laptop I’m using,



Can confirm this also happens to me.


GPU: RX 5700

Sent my crash log to @bug-files

1 Like