Creature Rig/Animation Help! My rig keeps spinning and animations wont work

Hello! So… i have this creature i’m trying to create for a dev project of mine. Its called a grickuck, this is what it looks like:

For some reason when I load into the game, the creature just seems to spin very slowly, just lazily spins around and i have no idea why. That, and the animations wont play (The only three anims i have yet are a core, 2 idles, and a walking anim). I first tried to load the creature with the anim script (Which is the usual roblox anim script) in a creature, and tested it… that didn’t work, and it still spun around, and then i tried loading myself in with the creature as a startercharacter, which didn’t work and couldn’t really move very well.

I checked to make sure the HRP was the primary part of the creature, as well as make sure everything was unanchored and cancollide, except for the HRP which is unanchored and uncancollide.

This is the hierarchy of the creature:

Anyone have any thoughts on this?

Could you perhaps add a video of what you see so we get a better understanding of your problem.


Greetings, I have a suggestion that might be the solution to your problem.
Have you tried placing a R15 Player model inside the creature so it can run the animation through that? By doing that you can simply weld a part of the creature to the player model and it’ll move alongside with it.

Skjermbilde 2020-01-24 kl. 18.31.30
Once you’ve welded a part of the creature to the ROBLOX character simply set the transparency of that to zero.

I have done this many times before and it worked each time without any problems.

Hope this helped.

That doesn’t seem very practical for what i need :confused: especially cause its just gonna be adding more parts. There has to be another solution.

1 Like

I think it would be best to send a gif or a video of your issues so we can better our understanding of your issue as @RamJoT said

Would appreciate if you’d provide footage of the problem so it’s easier for us to help, but another way is receiving more information about the problem.
Such as we’re you able to open the rig inside the animation editor without any errors? Are there any parts that are situated near the feet since that may also interfere with the gameplay.

When you loaded the creature as a startercharacter where you able to look around and move around the X,Y,Z axis? Is any of the mesh boundaries stuck on something.

@NicolaiXeno @RamJoT

In this video I also try moving xyz… i can’t jump… and i can only seem to move left.

Have you Set the Hip-height correctly, your model’s feet could be stuck in the ground making it unable to jump and bugging out. I would suggest trying a higher one if you think it was already set to see if it can temporarily fix the problem.

1 Like

That worked! I’ll mark that as a solution in a min… but for some reason my animations for the creature wont play. What i did was I ripped the animation script from the normal roblox anim scripts… by play testing and copy pasting. Then i replaced the animations inside the script aswell as in the hierarchy of the scripts, the physical animations. But they wont work.