CSG Failures


I found this really annoying bug.

After unioning some parts to create smooth edges,shadows glitch out terribly.

Check out images to see more details.


Do you have the repro place for this? That probably shouldn't happen!


Do you have the repro place for this? That probably shouldn't happen![/quote]

This happens all the time, when unioning parts into long parts (such as a high rise building), there happens to be really bad shadows which don't make any sense


Is this tall enough?

Tried to reproduce what vortex posted but no luck

Silent, you should edit the OP to say that repro files are a necessity for bug reports here here because you must have the appearance of a wizard that people think can magically fix a bug just by looking at it.


Well... about that...


Sorry guys,I had file ready but forgot to post it

Here it is


I have another union with a shadow issue. The union is roughly triangular but produces circular shadows.

Lighting issues with unioned CornerWedgeParts

Without a repro place I'm unsure if this is a rendering issue, a CSG issue, or both :frowning:


Without a repro place I'm unsure if this is a rendering issue, a CSG issue, or both :([/quote]
But I did attach the file...
EDIT: Can rbxmx files not be attached? I've tried attaching as a zip file this time.


Yeah -- rbxm/rbxl files can be attached but rbxmx and rbxlx files cannot be attached:

I guess whoever was whitelisted the rbxm/rbxl files forgot about the xml equivalents.




Union rendering error:


Same problem as Crykee - here's some more material to work with.


User PearSprite has reported his unions disappearing after a few saves and working on it.
He's uploaded it here, in case it's still free-to-take when someone takes a look at it:

Trying to seperate the union will return Union Unsolvable -1.
The union in the free model is according to him:


Something quite interesting happened to me the other day. I created a place and made a union, the union looked a little funny. When I reopened the place the Union was gone and there was this error in the output.

SolidModelContentProvider failed to process http://www.roblox.com//asset/?id=29526480 because Unrecognized format

Which in turn links to a model created 5 years ago. http://www.roblox.com/Restraunt-Seats-and-Table-item?id=29526480

I haven't touched the file that it was saved to and I am unable to reproduce this in anyway. I've attached a model containing the union.


Whenever I try to union these two objects, instead of the NegativePart negating a section from the union it adds the entire NegativePart to the union (see image below). No clue why this happens but hopefully the information provided can help out to solve this issue.



ROBLOX stop making features and then leaving them to die.

  • Increase the polygon limit
  • Pre-loading of unions
  • Better CSG union calculations
  • Box collisions (for lag reasons)
  • Multiple materials
  • Less buggy behaviour (invisible unions, errors)
  • Additional union operation commands (intersect)

Is there any valid reason to abandon any of these? We don't forget


"- Increase the polygon limit"
Pretty sure they haven't increased this because the format they store them in doesn't allow it

"- Pre-loading of unions"
Yes please

"- Box collisions (for lag reasons)"
Khanovich said he'd look into it if someone provided him a game that had lag issues due to CSG physics

"- Multiple materials"
I guess

"- Additional union operation commands (intersect)"
You can do this with plugins -- there's a function for it listed on the wiki, and if you're not a scripter, you can use this: http://www.roblox.com/CSG-Intersect-and-Brute-Force-item?id=248826344 (you'll probably like the brute force even more than the intersect)

"- Less buggy behaviour (invisible unions, errors)"
"- Better CSG union calculations"
Apparently the issue is with Geometros and not them, but it's weird considering that I can inject meshes with almost 100% success with good MeshData and PhysicsData. I would assume the problem is with ChildData.


Though when you inject a model as a union you're handing it a blueprint you already figured out and saying "do this for me". When you union 2 spheres together you're not telling it anything besides "here's these 2 things, put them together for me" so it has to figure out how to combine them in an expected manner ("solving" it).


All I'm giving it are coordinates and faces. I could convert every BasePart to coordinates and faces and that would work, but you aren't able to union regular parts together at odd angles, so I assume ROBLOX doesn't do that.