CSG Failures


Well that's quite the interesting effect. That's definitely something we'll take a look into, but as with all things CSG, it may take a while.


Not quite, if there's an intersection in CSG, it has to take the two parts, and find only the outside exposed faces, and clip them to size, then weld the vertices so that it's all one outside continuous mesh. When you set the mesh data directly, none of that calculation has to take place

What causes the CSG to mess up in most cases is coplanar intersecting or touching faces, CSG is bassed on a CAD solver, and CAD does not like to handle coplanar intersecting things, as the tools to make CAD parts inherently never run into those scenarios



The two parts in the attached file crashed Studio when I tried unioning them.







I was unioning some simple wedges and parts and I got this. It has a surface missing on the top (which was the bottom when I made it).

EDIT: also one of the wedges that was supposed to be part of the union disappeared. You can probably find it if you separate it.


I separated them and unioned them again in a different order and it turned out looking fine. Thanks for the find though!



If you open a place in Studio without internet and CSG anything, it will error because PSGPhysics is not in offline mode. :frowning: cri

Also, BIG CSG issue ...

If you add a texture to a CSG part, it either ruins your FPS and drops it significantly, OR, it only shows on 1 face of the Union.


I can't union the parts under the "Frame" and "Glass" models (separately). I've tried making smaller unions and then building it up from there but I can't seem to so it.

I need the "Glass" union to looks similar to the "Walls" union (e.g no z-fighting on the transparent parts so that it looks like one large smooth piece of glass)

test.rbxl (142.4 KB)


It appears that CSG doesn't support mesh offset :confused:

1) Insert a part into studio and then insert a block mesh
2) Give the mesh some offset
3) Union the part and the mesh will be unioned but it will be positioned where it would of been if you didn't give it any offset.


I tried to union this:

And it failed and made these strange missing parts to the negitive part.

Model file: Failed CSG union.rbxmx (49.2 KB)


Lately with the introduction of Team Create we (EBR) have noticed that unions would randomly disappear and not show, this would however only affect random people and happen randomly so I got no idea how to recreate this. However I figured this was just an issue with Team Create since it is still in beta. HOWEVER!

I was wrong! And it now appears to be the case that unions can randomly disappear in regular studio as well which is quite annoying if I may say so myself. The invisible union found in the .rbxmx file below should look like this, but yeah… It is invisible.

InvisibleUnion.rbxmx (25.1 KB)


It has been stated a few times by staff members that CSG in Team Create is still a work in progress. Avoid using CSG operations in Team Create for the time being.


We don’t really use Team Create yet, but the stuff I reported is not from Team Create, it is in solo studio.


You sure that didn’t happen after opening the place in Team Create? Like does it happen for a new place as well if you don’t use Team Create at all?


This place has never been in contact with Team Create and the unions are pre-Team Create’s release as well. The place we’ve used to build in Team Create was hosted by another user.


If you had the unions in Team Create at some point, then that’s probably why they’re not showing. It’s a bug (reported in the Team Create thread already)


[quote=“DieSoft, post:57, topic:16475”]
This place has never been in contact with Team Create

The unions in the place are also pre-team create, so they haven’t been in contact with a team create place.

Group project game freezes for all members

No idea why but in the repro file I have attached, the union and negation will crash studio no matter what if you try and put them together. I’ve tried remaking the negated part and separating the large union and only trying to union part of it with that negated part at first and so far it has crashed studio every time without fail. It’s not a huge deal for me but I thought I’d leave it here in case there is something that can be done about it so it doesn’t happen in the future.

Union That Crashes Studio.rbxl (18.6 KB)


Studio Version:

Computer Specs:

Unions not being Solvable