CSG Failures


#103

Use the .rbxm file i provided


#104

Oh, my bad. Forgot about the first post.


#105

It’s all good man. We all make mistake. Let me know what happens!


#106

wood
Yup, you can see how the material is freaking out, as if it handled too much than it should.
You can see the same issue if you set the part’s size to it’s maximal size of 2048,2048,2048. It’s even more clear if you increase the size inside it’s Mesh object if it has one.


#107

yep, experiencing this too, on every single union I make…


#108

I’ve been having an issue with UnionAsync where some geometry fails to union far from the origin. It gives an error along the lines of:

Triangle limit exceeeded: limit 204, needed 818.

This is obviously erroneous as the triangle limit for unions is much higher than 204. If you move the parts closer to the origin, it unions totally fine. Additionally, every time there is an error, the ‘limit’ it cites is different.
At the moment for my game I use live CSG to union floors together, and this error occurs about 80% of the time (it usually doesn’t occur with fewer parts). I’ve temporarily fixed it by moving groups to (0,0,0) when I union them.

Here’s a repro file containing an example of parts that won’t union:
UnionRepro.rbxl (13.9 KB)

You can either run the place so the script in ServerScriptService calls UnionAsync, or you can manually union the parts through the taskbar - either method should give the same error. This is the same problem that @eric5283 mentioned a few replies up.

Also as a sidenote the error message spells ‘exceeded’ with three e’s haha


Union failed: Triangle limit "exceeeded" (Triangle limit bug)
#109

Thanks, we’re investigating why this happens.

Let’s see if we can address the immediate issue with a flag while we fix the underlying issue. Flag changes are disabled for a few more hours due to the federal holiday in the US, but should go through today.

update: this should be addressed for now.


#110

I’m running into error code -25. It happened to one union but after I saved and relogged onto Studio, I ended up losing 3+ hours of work. It appears all of the unions I worked with today, ended up breaking.


Here’s the file to one of the unions:
broken union.rbxm (5.8 KB)


#111

EDIT: Appears to only happen on wood. Might be wrong, but I doubt it.

So I posted about this issue earlier where union textures, particularly wood, particalized themselves. Well I discovered something about it.

Basically, if you do the union operation close to the origin, the texture is created normally:

However, the further you move away, the bigger the sections get:

This issue occurs 100% of the time, no matter the place. No repro file is needed for this one since it happens across places.


#112

This appears to be a normal side effect of floating-point errors, with no clear solution.


#113

Thanks for the info. Makes sense it’s an issue with floating points. However, I’m assuming there’s some obvious fix for it, since this union texture error has only been happening for around a month. Before that, I never experienced the issue, so whatever they did in studio at around that time might be causing it or making it more noticeable.


#114

One of my favorite things to do is make 3D flooring, and it’s very hard when you have to do every single union at the origin, even if your game is sprawling or just not near the origin.


#115

This indeed only started a couple of weeks ago, didnt have any issues with it before.


#116

Alright so for almost a month now i have been experiencing unions going invisible for no reason when i exit and re-enter my game in studio. I didn’t mind at first because i really didn’t use unions as much, but now when i am modelling items, it really is an issue. I have looked around for solutions to fix them, but there doesn’t seem like there are any. Like for most people, the unions are still there, but are completely invisible. When i try to rotate, move, or re-scale the unions, nothing happens to them (like some people have suggested trying). When i separate the union, it just vanishes without a trace. Here are some images of where it has happened:

image

As you can see, the selected regions are where the unions are, but are not showing up. I am not sure why or how this happens, but it is getting pretty annoying. Thanks for reading, hope this gets sorted out soon!

Edit: Not sure if this will help, but every union that is invisible is a union made up with only cylinders.

Edit2: Here are the model files as well:

Pistol.rbxm (21.4 KB)
Sniper.rbxm (79.6 KB)


#117

Sometimes after creating some specific unions and publishing the game, upon reopening the unions would disappear.

I’ve tried un-unioning them but when I do it just disappears. Deleting them and pasting them back in doesn’t really do anything either. I do think I have a slight idea of what is happening…in a sense any unions I would resize would end up going invisible (Disappearing) after publishing and re-opening on studios.

There are other unions, that I haven’t resize whatsoever and they are still present, but as of recently any unions I make and resize altogether would just disappear the moment I publish and leave studio, and join back.

[ Before the Unions disappearing, upon publishing and leaving studio, and entering again later ]
unknown

unknown%20(1)

[ After a few hours, upon re-entering studios to find the unions completely bugged out disappearing… ]
unknown%20(2)

unknown%20(3)


#118

Recently I found a bug tied to the use of cylinder meshes/parts and levels of separation causing the position in workspace to become offset from it’s original position. I made a few videos to demonstrate what I mean by this in studio.

Video 1
Video 2
Place File

A quick explanation of the video

  • Going through different stages of unioning the parts
  • At the end, separates all the parts again and compares the position + starting orientation
  • It basically shows how the parts keep getting offset over time the more union operations are done

#119

While helping a friend make a military truck with tracks I negated a Cylinder and then made a union with a part. I then got this error.
image
This occurs 100% of the times in Roblox Studio (64 bit, but should happen in 32 bit).
Here’s a repro file. Repro.rbxm (17.8 KB)
The repro file includes another Cylinder in the exact same size but when you union then it works as expected.

Reported it since it haven’t reported error code -25 with a repro before


#120

Was building a keycard slot holder for my SCP game. Today the union went invisible and no fixes atm.
csgerrorNegative25.rbxm (6.1 KB)