CSG operation shortcuts not working

Reproduction Steps

Attempt to use any of the CSG operation shortcuts (Ctrl+Shift+G to Union, +U to Separate, or +N to Negate).

Right-click on any BasePart in the Explorer window.

Expected Behavior

I expect using the CSG operation shortcuts to perform the requested CSG operations, and for the available CSG operations to appear in the right-click drop-down on BaseParts in the Explorer window.

Actual Behavior

Attempting to use the operation shortcuts does not perform the requested CSG operations.

Right-clicking on BaseParts or Unions in the Explorer panel does not give any option to perform CSG operations in the drop-down.

Workaround

The right-click drop-down works as expected in the world view, showing the CSG operations that are available. This does not give sufficient feedback about precisely what I’m about to perform the operation on, however.

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Constantly

EDIT: Changed title to remove mention of the explorer pane, as that it intended behaviour. Post body remains unchanged.

Thanks for the report! Could you provide a video showcasing this issue?

1 Like

Certainly! Sorry about the late response - OBS had problems picking up the cursor and the dropdown menu, but I got there in the end.

Hello!

Regarding the shortcuts not working-- is this still an issue? We are unable to reproduce it in production at the moment. If it is, please let us know the reproduction steps (if it changed), your Studio version number, and the list of beta features you currently have enabled.

Additionally, for the explorer context menu. Internally, we feel like simply adding it to the context menu isn’t the correct solution, and are currently working out methods to improve the context menu as a whole, which would include more options in the explorer context menu. However, while that work goes on, we are trying to keep the changes in the menu minimal.

2 Likes

I can confirm this is still an issue as of version 0.578.0.5780566, and the repro steps have not changed; pressing Ctrl+Shift+G does not perform a Union operation with multiple parts selected, but the viewport context menu option works fine. My currently active beta features are:

  • 3D Import gLTF Support
  • AI-Powered Code Completion
  • DragDetectors
  • Face Capture
  • IKControl Joint Constraint Support
  • Live Animation Creator
  • Material Generator
  • Multi-Cursor Script Editing
  • New Character Controller
  • New Text Chat Service
  • Notched Screen Support
  • Reconnect automatically to Team Create
  • Save rig with Animation
  • Scale factor for Models
  • Selection Improvements
  • Terrain Editor Improvements
  • Upgrade Shorelines

I’ll test this and get back to you asap!

2 Likes

Do you perhaps have custom shortcuts overriding it? I turned on all of the beta features you have, but the shortcuts still worked for me (Ctrl + Shift + G).

Check in File > Advanced > Customize Shortcuts, then search for Union.

1 Like

I just wanted to add, this is not indicative of anything being amiss, it’s the expected behavior. The CSG operations are only ever shown in the 3d Viewport context menu, never the Explorer one.

1 Like

I can confirm I don’t have any custom shortcuts overriding it - I searched both ‘union’ and ‘ctrl+shift+g’ and both returned only the union shortcut (as an aside, I didn’t know we could customise shortcuts, this is sure to come in handy!).

Good to know! Should I file a suggestion for this? I often use the explorer pane to select parts rather than the viewport because I tend to do it by name or by model, so having the option in there also would be a help.

Out of curiosity, does your Ctrl+Alt+G shortcut (Group as Folder) work?

1 Like

It does! As does Ctrl+G to group as model.

Hello @Auhrii I am looking into this bug and I cannot reproduce the hotkey issue either.
Is it possible that this is a plugin issue? If you disable all plugins does the problem go away?

What about the shortcut editor? If you do file->advanced->Customize Shortcuts, then press ‘g’ to search for rows that contain a G, do you see anything else in the ‘shortcuts’ column that looks like a conflict?

Lastly, are you on windows or a PC?

Thanks

1 Like

I can confirm this is still the case for me with all plugins disabled, and there are no conflicts shown in the shortcut customisation pane.

I’m currently running Studio version 0.604.0.6040509, on Windows 11 Pro version 10.0.22621.

Ctrl+Shift+G is also still listed as the Union shortcut in the context menu, and the context menu button works as expected, however the shortcut does nothing. The same is the case for Ctrl+Shift+U for Separate, but Ctrl+Shift+N to Negate and Ctrl+Shift+I for Intersect work without issue.

What happens if you click the "Restore Defaults’ button on the keyboard short customization pane?
Does that help?
this really seems like something about your particular configuration

1 Like

Okay, I’ve asked others here to try and reproduce on PC machines, and they do not see the problem you are seeing.
So for now there’s nothing we can do on our end. Unless we can reproduce it, we can’t fix it.

Also, note that as @DeFactoCepti stated earlier, we won’t be adding these to the explorer menu. That has been left out by design and we do not want to add complexity to that menu.

1 Like

@Auhrii another suggestion if “Restore Defaults” does not work in the shortcut customization pane:

It is possible they you some software catching those keys, not Robox. Like, AMD Radeon software would toggle streaming using this keyboard shortcut. I would recommend to close as many as possible items in system tray area and try again

1 Like

All this time, it appears to have been AMD’s Radeon Adrenalin software. I did disable its hotkeys a long time ago and so it never occurred to me that it might be a problem, but reinstalling it since may have wiped that setting. Disabling Radeon hotkeys once again appears to have solved this issue, thanks!

Awesome! Thanks for reporting back!

We are closing this bug now since the hotkey issue is resolved, and the Explorer menu is not going to be addressed, after we spent time discussing the design.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.