CSG Returned Error Code -21?

I was playing with some simple unions earlier when I stumbled upon a problem. I tried to union something when all of a sudden, the negated parts weren’t responding to the part I was molding. I thought, “We’ll that’s odd, I’ll just try that again” - I try again and that’s when this error popped up. I’ve never seen any error like this before, so I’m assuming it’s rare or something critical. However, now I can’t seem to union anything without it either giving an error or ignoring a negated part. Does anyone know why this error occurs, and is there anything I should do to prevent it from happening?

I also included a screenshot of the pop up, as well as the model of the union I was trying to accomplish…


BadObjects.rbxmx (67.3 KB)

3 Likes

Then again, this could’ve just been a one time deal. I retried the union in a different studio and it works just fine. Let me know if anyone else has troubles with the same union, or if they’ve encountered this problem themselves.

1 Like

Hey, and thanks for taking the time to report this.

Indeed error codes from the new CSG system are something we are always interested in. Where we’ve seen -21 before is in cases where the CSG child data is for one reason or other, unavailable.

The behavior you describe seems to point to a problem with storing or retrieving the necessary data.

Was the model published, or entirely local? This might help us narrow it down.

Thanks

2 Likes

Entirely local

2 Likes

On the file, 2 of the negate parts (on the farthest side) seemed “blank” - I couldn’t select them, just as if they didn’t exist.
I took fresh bricks, scaled, oriented and positioned it back to it’s place and it worked.

1 Like

Sorry for the bump but…

I was using :SubtractAsync on parts and I ran into error code -21.
The part that was being unioned was completely fine, however the subtracting parts had
the property Archivable false. I made sure Archivable was true and it worked fine…?

(This is the only topic about error code -21 I could find)

1 Like