Cursor is locked to middle of screen after teleport

Reproduction Steps

This issue occurs after teleportation between places in a universe. This can be experienced in games such as my own, Specter - Roblox, but I have seen players reporting it in other games that include teleportation between places as well.

System information: Windows 11 Pro, AMD Ryzen 7 5700x, 32GB DDR4 RAM, RTX 3070

Expected Behavior

After teleportation, your cursor should be free to move around the screen.

Actual Behavior

Your cursor is unable to move, while locked to the center of the screen. This bug may be connected to the teleport occurring while the player is in first person, however, I have not tested this theory. In both my affected games, players teleport while in first person, with the mouse “locked” to the center of the screen.


I have found the only fix to be unfocusing from the game via tabbing out or pressing the Windows key and refocusing. However, most players do not recognize that this is possible and end up leaving instead. Considering that this happens > 50% of the time from my tests, this is likely causing a drop in retention.

Issue Area: Engine
Issue Type: Other
Impact: Moderate
Frequency: Often


I’ve received several reports about this and wasn’t sure what it was until now. As you say, my games also have teleporting and that’s when it occurs.

This is really bad if a user is prompted with a UI button on server startup - as they won’t be able to close it.

1 Like

Happens a lot in bedwars, engineers can try playing that game to reproduce it.

happens 8/10 times

You’ll get it if you’re shiftlocked and typing in a UI box.

ttry to click crtl and then move your mouse, it happened to me and what i said fixed it

This same issue seems to be happening, not sure if this was previously resolved or not but I’ve been having those same issues.

1 Like

I am still receiving reports of this as well. PC users can solve it by alt-tabbing, but this is incredibly friction-filled.

I have been able to repro this bug consistently. It happens 100% of the time when you teleport in first person. It happens sometimes when you teleport in third person.

@thirdtakeonit would you be able to let us know if this bug has been filed/is being looked into? Users thought this was an issue with my game, and it has affected retention + the likes/dislikes ratio. I implemented a hacky workaround which is not foolproof - this is rather pervasive + severe.

1 Like

Hey everyone!

We’ve been looking into this and are currently working on a fix!

Thank you for your patience.


This also happens in the desktop app. Occurs on both Windows and Mac. In the desktop app it is much more common to happen, since you aren’t exiting the Roblox app and I guess shift lock isn’t disabled. I’m not really an expert on it though. It is a painfully annoying issue. If you are playing an FPS game and then leave and join a different game, your camera is also locked.

There’s also the issue where you’re forced in shiftlock, even if you don’t have it on.

1 Like

I’ll test this case, but the fix should account for this situation too. Thanks for the input.

1 Like

Do you have an example of this? Could it also be the cursor locked in the middle of the screen from previously being in first person?

I’m not sure about that, but i know to unlock your cursor from being stuck in the middle of the screen, you need to alt tab. The shiftlock thing can happen by just joining. I think it can’t happen on mobile and it can happen in studio. Your mouse is free, but when you move your camera, your character follows it like if you were in first person or in shiftlock. Only way to fix this is to rejoin and even then you might need to rejoin multiple times.

I’ll try to get an example tomorrow.

here’s an example

Thanks for the example! The fix I have resolves this issue too. I’ll update this post after the fix goes live.


Thank you! It’s a pretty tiedious bug.

3 days later, still no fix. But I am just guessing that, hopefully, in the next update it is fixed. This bug is insanely annoying.

1 Like

The shiflock thing is annoying when it happens on mobile

The solution is to join any of those games that put the shiflock button on the GUI (like ToH), press it and wow, solved

And what about the locked mouse when teleport, It fixes when, with the mouse wheel, put in first person, then return to the normal distance and solved again!

Let’s hope it doesn’t take too long to be fixed