Curve Animations Do Not Play for Non-Humanoid Objects

Reproduction Steps

1. Download the place file linked below
2. Test both “Normal” and “Curve” Animations and verify they both work using the Animation Editor and AnimationController.
3. Upload both animations to your account.
4. Switch the AnimationId in the script to the “Normal” ID.
5. Click “Run” to verify it works.
6. Switch the AnimationId in the script to the “Curve” ID.
7. Verify that the Animation does not play.

AnimationCurveNonHumanoidBug.rbxl (42.4 KB)

Expected Behavior

I expect the Curve Animation to play using the AnimationController on “Run”

Actual Behavior

The Curve Animation is playing but does not actually move any objects.


There is no work around.

Issue Area: Engine
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2022-09-07 09:09:00 (-05:00)
Date Last Experienced: 2022-09-08 14:09:00 (-05:00)


Happening for me too, I noticed something as well.

local animation ="Animation")
animation.AnimationId = ""..tostring(walkAnimID1)
animation.Parent = game.Workspace
local animationController = petEquipped.AnimationController
local animator = animationController.Animator
local animationTrack = animator:LoadAnimation(animation)
animationTrack.Looped = true
print(animationTrack.Length, animationTrack.Looped) --Does print out values

It appears that the animationTrack does get returned, but it refuses to play. And I’ve tried this with both AnimationControllers and Humanoids, any rig that does not seem to resemble a player character does not run the animation. FYI, it plays fine in the animation editor, but doesn’t play outside of that.

I really hope roblox could fix this sooner, because this is really stalling my development.


It happened to me too! I tried using a walk animation my animator made for us and it didn’t work! This problem has been going on for a really long time and Roblox has done nothing about it

1 Like

Thanks for reporting this, we are working on a fix.

One workaround is to rename the root part of your model (named “Root” in your test place) to “HumanoidRootPart”. In existing curve animations for that model you’ll also need to rename the Root folder to “HumanoidRootPart” so that it matches. Then the animations should play correctly.

Alternatively you can use Keyframe animations until this is fixed.

Has it been fixed yet? I have practically finished a game and I have been waiting on Roblox to fix this issue.

We’re planning to release the fix for this on Wednesday, I’ll post an update here when it’s available.


Thank you so much! I have been using third party scripts to get the animation to work but now it should work without third party extensions! (roblox w for once)

Apologies for the delay, this has been pushed to early next week for some additional testing.


Ok I’m waiting! Same problem with mine!

I arrived late, has it been solved or is it still in maintenance? I have the same problem

This should now be fixed in the latest release (538). Let me know if you’re still encountering this issue

I am still having this problem. My animations work fine in the animation editor but do not work properly in-game.

local AimAnim ="Animation")
AimAnim.AnimationId = GunConfig.Animations.Aim

local RestAnim ="Animation")
RestAnim.AnimationId = GunConfig.Animations.Rest

local ReloadAnim ="Animation")
ReloadAnim.AnimationId = GunConfig.Animations.Reload

local BoltAnim ="Animation")
BoltAnim.AnimationId = GunConfig.Animations.Bolt

BoltAnimTrack = Humanoid:LoadAnimation(BoltAnim),
ReloadAnimTrack = Humanoid:LoadAnimation(ReloadAnim),
RestAnimTrack = Humanoid:LoadAnimation(RestAnim),
AimAnimTrack = Humanoid:LoadAnimation(AimAnim),
1 Like

Can you send me one of the animations that isn’t working? Just the assed id is enough.

There is a separate issue with quaternion curves using auto-tangents which can cause them to work in the Animation Editor but not in-game. So if these are using quaternion curves that could be the issue here. This issue should be fixed in the next few releases. If this is the issue you’re seeing a couple of workarounds are to change your key interpolation modes to linear, or to convert them to euler angle curves.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.