Custom animation not working on custom character (r6)

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!

I want the character to start moving with the animation

  1. What is the issue? Include screenshots / videos if possible!
    well I have an animation done and still not working and even with my normal character there is no animation


  2. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    yes, still not working
    here’s the script :

local char = script.Parent
local humanoid = char:WaitForChild("Humanoid")
local walkAnim = script:WaitForChild("Walk")
local walkAnimTrack = humanoid.Animator:LoadAnimation(walkAnim)

	if speed > 0 then
		if not walkAnimTrack.IsPlaying then
		if walkAnimTrack.IsPlaying then

should be Running

1 Like

Uh I’m not even kidding I checked again and again to see if I made any mistakes and I sitll managed to do a dumb one so yeah thank you for this It work (took me the whole day…)

Ah well, oversights happen

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.